Enemy Territory Quake Wars Problem

I get a segmentation fault when I try to install the Enemy Territory Quake Wars demo.

Does anyone have any experience of this problem?

I discovered the Quake Wars Linux demo can’t be installed while X is running. To overcome this problem, I logged into root and then changed my run level to init 3. I installed the demo and then changed my run level back to init 5. Everything works just fine.

I was able to login as root and change the runlevel but how do you run a .run file to install?

You can run a run file by typical sh file.sh or ./file.sh. If you see a permission denied message, you will have to make the file executable. The easiest way to do that is right click on the file and select the tab that allows you to put a check mark in the executable box.

I actually took these steps and successfully installed, I think, but I cannot get the etqw file to run.

How do you know the game successfully installed and what problem are you having getting it to run?

Well, the installer said it was successful but when I try to run the etqw file that is supposed to run the game, it does nothing. So, I have now installed the game to /usr/games/local/etqw.1.1 as root so I will see if that helps out. I’m in class now so can’t check just yet but if I continue to have problems, I’ll post back.

Ok, I installed the demo to /usr/local/games/etqw.demo and I try to run the file etqw but it says

justin@dorm02116:~> sudo /usr/local/games/etqw.demo/etqw
./etqw.x86: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

Clicking or double-clicking the etqw file doesn’t do anything either.

zypper in libSDL-1.2.so.0

Well, that acted like it wanted to work but I got this…

justin@dorm02116:~> sudo zypper in libSDL-1.2.so.0
Loading repository data…
Reading installed packages…
Resolving package dependencies…

The following NEW package is going to be installed:

Overall download size: 179.0 K. After the operation, additional 466.0 K will be used.
Continue? [YES/no]: yes
Retrieving package SDL-32bit-1.2.13-104.1.x86_64 (1/1), 179.0 K (466.0 K unpacked)
Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)

Abort, retry, ignore? [A/r/i]: r
Failed to mount cd:///?devices=/dev/sr0 on /var/adm/mount/AP_0x00000001: No medium found (mount: No medium found on /dev/sr0)

Abort, retry, ignore? [A/r/i]: r
Failed to provide Package SDL-32bit-1.2.13-104.1. Do you want to retry retrieval?

[openSUSE 11.1-0|cd:///?devices=/dev/sr0] Can’t provide file ‘./suse/x86_64/SDL-32bit-1.2.13-104.1.x86_64.rpm’ from repository’openSUSE 11.1-0’

  • Can’t copy /var/adm/mount/AP_0x00000001/suse/x86_64/SDL-32bit-1.2.13-104.1.x86_64.rpm to /var/cache/zypp/packages/openSUSE 11.1-0
  • Can’t provide ./suse/x86_64/SDL-32bit-1.2.13-104.1.x86_64.rpm : Can’t copy /var/adm/mount/AP_0x00000001/suse/x86_64/SDL-32bit-1.2.13-104.1.x86_64.rpm to /var/cache/zypp/packages/openSUSE 11.1-0

Abort, retry, ignore? [A/r/i]:

After a couple times, I put the openSUSE CD in because I’ve had to do that for a few updates but that didn’t help either.

Well, I actually was able to download SDL 32 bit with Yast and it worked. I haven’t played the game yet but it loaded.

The game works. I’m disappointed in the performance but it worked! The key to most of it was using the terminal with the sudo command for EVERYTHING.

The packages contained on the CD become outdated quite quickly. For that reason,. I disable my DVD repo. Also, it’s a pain having to insert the DVD every time Yast wants files from it. Far quicker to go upstream and download things like SDL from Packman.