Endless Loop - Installer keeps "installing" at boot


I installed OpenSUSE 11 on my new A305 Toshiba laptop with Windows Vista installed. HEre are the sequence of events:

  1. Downloaded and burned the 11.0 64-bit edition.

  2. In Windows, I ran the SUSE Installer program from the DVD I created.

  3. The installer quickly did something (too fast to tell) asked me to reboot, so I rebooted.

  4. I was not given a boot option and I was automatically launched into the SUSE install routine.

  5. I changed my mind to set up SUSe right away, but noticed that I could not because the install routine keeps happening (even with the DVD out… which it eventually asks for).

  6. I figured I would go ahead and install SUSE, and it went pretty well.

  7. I was able to boot into SUSE right after installing, but wanted to go back to Windows.

  8. When I select Windows on the GRUB menu (which was supposed to be the default but SUSE is), I am still stuck in the install routine.

  9. I noticed what looks like the standard boot option screen flash by. As soon as I see it, it is gone. It is too fast to tell what the choices say.

  10. I try to use F8 druing boot to get the menu, with no luck. I tried to hold Shift or space (looking for some reaction) during boot with no luck.

What do I need to do? I am sure there must be a simple fix.

Please help!:confused:

Are you sure you completed the installation process? Do you remember seeing an installation activity specifically for installing the boot loader? If so, what was done?

The installation completed without errors. I recall verifying the GRUB menu options at the final installation screen (before hitting “go” and everything changes).

It began repartitioning and formatting the new Hard drive allocations (I adjusted the default sizes… the default size took up too much HD space away from Windows) and then installed the images. I didn’t watch all of the details after that, except that I checked the progress bar a couple of times, but I know I was presented with a nice SUSE desktop after the install.

After I lchecked out my new SUSE desktop, I selected restart from the GNOME menu. At the bootup, I had a nice GRUB menu with SUSE and Window Vista as my choices. When I chose Windows, it began the bootup process for Windows. Then I can barely catch a screen (it is so fast) that looks like the familiar boot options for Windows screen. It appears something is automatically selected and then the SUSE installation begins.

If I select SUSE at the GRUB menu, I will go to the SUSE OS bootup and get to that desktop.

I am wondering if I will be able to find a boot.ini in the Windows partition from the SUSE desktop and be able to edit soemthing out that may point to a SUSE install routine. It would make sense that SUSE would reset whatever it did to my boot options in Windows, but that does not appear to be the case.

Here is an update:

I spent an hour trying to do root tasks without being able to log in. I spent the time trying to figure out how I put a typo in my new password; when I finally realized OpenSUSE has my Caps Lock backwards! Arggh!:mad:

Whenever Caps Lock is enabled, it is disabled in SUSE! I tried setting to another US keyboard that was a Toshiba brand, but it was the same problem. Anyhow, I got to the boot menu. I didn’t notice anything wrong, so I thought I would get my Windows MBR setting back by hitting “restore MBR” (which said it was last saved 2 days before I tried installing SUSE). - What I ended up getting is only the Windows boot with this SUSE installer still forcing me to go through the install routine.

I started to use the repair options until it got really late and the thought hit me that I will end up where I started. Meaning, I don’t see where the SUSE Repair is going to fix my Windows boot record by installing GRUB again, it will only boot my partitions.

I have never had an install of SUSE do something like this!

After some pain, and lack of sleep, it is fixed!

I tried the SUSE repair; which happened to fix my CAPS Lock quirk. The GRUB menu had to be set up manually, but didn’t really change anything.

So, then I tried running fixMBR according to instructions from Microsoft using the command prompt (DOS). I still had the problem with no GRUB, and it was then I realized it was not the MBR, but something loading at the beginning of the boot load. So, I reinstall GRUB (again).

I used the pause function (almost forgot that existed) to catch the screen (this was difficult being so fast) and I was able to see an option menu to choose the SUSE loader (real name escapes me), but I can’t choose Windows. The next screen (within milliseconds) displays OpenSUSE 11 Installer with different options in the booting, but no option to choose Windows.

Thinking I can outsmart this, I used SUSE to browse and find an OPenSUSE text file in my C Drive that has boot instructions and a time delay of 0, so I change it to 8 seconds. Well, that does me no good because on reboot I get 8 seconds to look at a screen that only lets me choose OpenSUSE! :mad:

Then I browse the C drive and get rid of the Open SUSE files and folder (4 files altogether). I could not find a Boot.ini knowing the BCD is the new Vista thing, but it can still use a Boot.ini and I was hoping SUSE made one – no luck. Once I reboot and choose Windows from GRUB again, this results in a choice to boot to the Open SUSE installer with nothing happening because the files are gone.

I go back to the Windows help file and follow instructions on how to rebuild the BCD (because it cannot be simply read like an ASCII file). I could have made a typo (because this is the wee hours of the morning), but I did the rebuild with the program telling me I already have Vista partition to boot to. I did set the delay to 8 seconds to view options. Whatever mistake I made, Windows detected the BCD wasn’t quite right; but I was in the Windows boot manager finally! I was given a choice to boot to safe mode; which I tried first. Actually, the auto-detection of the error was great, because Windows asked to fix it and wholeheartedly said YES.

I was able to boot into Windows normally after that. So, after a painful experience, I am back to my Vista desktop!

**One important thing to note: The BCD rebuild did not affect GRUB at all. **

Hope this helps someone out there!


i suffered the same BCD-boot issue of Vista and found the cause of it. Maybe this helps someone to fix the opensuse-windows-installer.

While preparing the installation of opensuse11 within vista the installer places an additional entry into this BCD-file and makes it default for next boot.
Sadly this task unnecessarily overwrites the path for the first OS-Entry or the previous default Entry (havent tried that ;)) into some boot-record-file for the opensuse installation (\grldr.mbr).
This is the problem why instead of vista the opensuse-installer will start again and again until you use fixing-options from the vista boot medium. Please note that “bootrec /fixmbr” and “bootrec /fixboot” wont solve this - needles to try.

In my case these automated fixes didn’t work and so i had to dig deep into editing the BCD-file from within vista’s rescue console and while exploring the contents of that file with the help of bcdedit (integrated vista cmdline-tool) i recognised the fault as described above.

With the help of bcdedit i could fix the path back to \windows\system32\winload.exe
and now my vista is runnable again.

For anyone struggling with the same task to manually repair the BCD-File contact me since this is not a vista forum.

By the way … i advise to make a Backup-Copy of this file - its only 32k.