Encounter a problem when start Digikam application


I installed digikam application by yast.
When I start digikam with krunner, no any response.
Then I run it in console, get below result:

QSqlDatabasePrivate::removeDatabase: connection ‘ConnectionTest’ is still in use, all queries will cease to work.
KCrash: Application ‘digikam’ crashing…

[2]+ Stopped digikam

Hope I can get help!

It looks like your database connection is still open. The first time Digikam startup it wants to know where you want to store your images, you should have gotten a popup box asking where. Try logging out and then back in to see if it will colse the connection.

If restarting the computer doesn’t fix it, can look for where digikam keeps the config folder and delete or rename it? (sorry, I’m not in front of my KDE box right now to see where the config files go).

I don’t know how you have yours set up, but my data is stored in the pictures directory in database files. Could try renaming those and see if digiKam creates new ones? I’d try the reboot and config directory first though.

I tried to restart the system, but the problem also exist.
When I run digikam, it will create a “digikam4.db” file in ~/Pictures/ directory.
Then I renamed the Pictures directory, it’s create a file “Pictures” in ~/ directory now when I run digikam.
I don’t know where is the digikam’s config file?

In Dolphin there is an option to show hidden files (files and folders are hidden by putting a period in front of the name e.g. ~/.digikam would be a hidden directory called “.digikam”.) I don’t know if there is a .digikam directory, or if it is under some .kde or .kde4 somewhere.

Hi, dragonbite,

Thank you very much!
I deleted the “~/.kde4/share/config/digikamrc” file, then start digikam, it’s ok now.