Enabling wireless Ethernet connection

My wired ethernet connection on my mobo suddenly died on me but I installed a USB device to give me a wireless Ethernet connection to my modem/router. The device is a Rosewill RNX-EasyN1 which I had previously bought a few years back just for this type of emergency situation.

In OS 13.1 I went to Yast | Network Settings and it was able to pick up the device as a “802.11 n WLAN”. I then configured the device and it eventually said it needed the “iw” package. I cancelled the configuration of the “802.11 n WLAN” temporarily and I then went to Software Repositories and added my OS 13.1 DVD back as an enabled device and then went to the software manager and it was able to find the 'iw" package from the OS 13.1 DVD and install it.

I then went back into Suse and configured the device and all went well. In the configuration I told Suse to enable the device at boot time. I then rebooted.

While Yast shows the device, when I go to KDE Configure Desktop and choose Network Settings in order to make a connection, the Wireless tab is grayed out.Therefore I cannot add the Wireless network connection that would allow me to use my device to connect to my modem/router and the Internet. This suggests that the device is not working hardware-wise in Suse 13.1.

I know the device is actually working since I am using it in other operating systems on my multi-boot computer without connectivity problems.

What do I need to do in order to get my wireless Ethernet connection working on OS 13.1 ?

You have to switch to NetworkManager in order to make KDE’s Network Settings or KDE’s networkmangement applet work.
They are just frontends to NetworkManager.

Open YaST->Network Services->Network Settings->Global Options, and activate “User-controlled using NetworkManager”.

If it still doesn’t work then you should post at least what wireless adapter you have for a start:

/sbin/lspci -nnk

You might have to install some additional driver or firmware.

What do I need to do in order to get my wireless Ethernet connection working on OS 13.1 ?

There is no such thing as a “wireless Ethernet connection”. :wink:
Ethernet is wired by definition…

Worked perfectly. Thanks very much !

Oops ! You are right.