Enabling touchpad tapping on a synaptics touchpad

11.3 and 11.4 do not come with touchpad tapping enabled; to enable this at the login screen add
Option “TapButton1” “1”
to synaptics.conf

Both KDE and Gnome offer synaptics configuration programs to access the other features of a touchpad.

Version 11.4, KDE installed.

Cannot get any sort of KDE touchpad configuration to work.

“Personal Settings” “Input Devices” “Touchpad” selection gives the following message:

“Warning: Touchpad configuration is not supported on this system. The synaptics driver is either not loaded or too old. Refer to the documentation for information about the required driver version.”

YAST tells me I have SYNAPTIKS version 0.4.0-9.2 “A touchpad management tool for KDE” installed. Other option is gsynaptics - a GNOME tool?? - not installed.

/etc/x11/xorg.conf.d/50-synaptics.conf contains:

Section “InputClass”
Identifier “touchpad catchall”
Driver “synaptics”
MatchIsTouchpad “on”
MatchDevicePath “/dev/input/event*”
Option “HorizScrollDelta” “0”

which doesn’t seem useful.

Where else to look/do?


A number of people have reported that with 11.3 also. I guess you could report it as a bug, or just wait until the software catches up with the newer hardware.

That sometimes happens to me, with a new Dell laptop (with openSuSE 11.3). If I directly boot into openSuSE, then things are fine. But if I first boot to windows, and then reboot (warm restart) into linux, I get that message. On an older (2004 vintage) laptop, I don’t have that problem. However some of the touchpad config doesn’t work there with 11.4, though it did work with 11.3.

As far as the default (tapping turned off) - that’s good. Windows defaults to it turned on, and people like me with a heavy touch have problems with the initial setup screens on Windows, before you get to a place where you can turn off tappig. The default of no-tapping is safer, and let people turn it on if they wish.

Actually, the tap does work on mine. But I would like the rest of its features to work, especially the up/down rocker between the left/right buttons.


The first posting was accurate, but a little too brief. So I will describe it in more detail. Also valid for OpenSUSE 12.1, for all desktop environments (KDE, Gnome, Xfce, LXDE, …).

  1. Make yourself root in the terminal (su):

Press Enter. Fill out your password, this remains entirely invisible, not even dots will show. Press Enter again.

  1. Install Beaver (Gedit used as root, sometimes causes trouble):
    In the terminal (use copy/paste):
zypper install beaver

Press Enter.

  1. In the terminal, still as root (use copy/paste):
beaver /etc/X11/xorg.conf.d/50-synaptics.conf

Press Enter.

  1. Add the following option, beneath the option that’s already there (use copy/paste):
Option "TapButton1" "1"
  1. Save the file.

  2. Reboot. Tapping should work now.

I do this but my problem don’t be solved.

You should put the new Tap option straight under this existing option:
Option “HorizScrollDelta” “0”

It only works when you put it at that place. Then save the text file and reboot your computer.

This thread was started in the wrong forum. Seems nobody saw the large banner at the top: Please don’t ask questions here. I’m going to ask a mod to move it.

Temporarily closing thread and moving to applications.

nntp users please don’t reply until I confirm thread is moved.

Thread moved and reopened.