Enabling desktop effects results in white screen

When I checked the “Enable Desktop Effects” box, the desktop suddenly dropped out: the title bars and borders from each window disappeared, then then the windows disappeared, then turned to a blank white screen with only the mouse pointer (still movable).

I rebooted the computer, but even in safe mode I still only get to a blank white screen. I can CTRL+ALT+Fx and get to a terminal. Any ideas on what I can do?

openSUSE 11.0 with GNOME
ATI Radeon X700 Video Card

At the boot screen type

runlevel 3

. You will get a console login. So log in as root. Type

edit /etc/X11/xorg.conf

Search for this section and hit A key - now you can write into this file. Do not change anything except this:

Section "Extensions"
    Option         "Composite" "Disable"

In your xorg.conf this option is set to Enable, Yes, or something. Change it to “Disable”.
save your file. (Hit the Esc key and type)

:save! xorg.conf





Good luck.

Or… this means that there ain’t no driver.
I go to init 3, and install driver. After, I use a command
sax2 -r -m 0=fglrx (for ati, or for nvidia: 0=nvidia)

Or there is some problem with the driver, just type:

glxinfo|grep direct

yo should get “direct rendering: Yes”