Enable zstd compression on your qcow2 files?

In QEMU 5.1 zstd compression of your qcow2 files was introduced.But it’s not described in the manual for qemu-img.

How do you enable it?

It seems to be an option for the qemu-img create command, so it’s only possible to use zstd when creating new images e.g. qemu-img create -f qcow2 -o compression_type=zstd ./test-with-zstd.qcow2 10

I guess it provide continuous compression in contrast to the current “old” compression feature which didn’t.

Hmmm, cannot get it to work:

qemu-img create -f qcow2 -o preallocation=off,compression_type=zstd /mnt/data-ssd/VM/disk1.zstd.qcow2 50G

Error:


qemu-img: /mnt/data-ssd/VM/disk1.zstd.qcow2: Invalid parameter 'zstd'

I am using qemu-img version 5.2.0

And it is built with zstd support?

I guess only the maintainer can answer that…?

Cleaning up old Forum threads while I’ve been gone,

If you wish to have this feature, you can submit a feature request to https://bugzilla.opensuse.org

TSU