Enable subpixel hinting for Opensuse 11.0

Hi all,
This is a collection of my knowledge and experiences (and majority successful) at trying to enable subpixel hinting on Opensuse 11.0. The main problem areas are: KDE3 (QT3), KDE4 (QT4), Firefox 3 and Openoffice.org.

I use a KDE 3.5.9 on Thinkpad R61 and my preferred font is Tahoma 8 pt size. I have an Intel 945GM graphics card.

General Subpixel Hinting:
Install the freetype2 package from opensuse-commnity.org. Details are at :- SubpixelHinting - openSUSE-Community.

This will enable subpixel hinting for all Qt3 applications, but will not enable it for any applications that use the cairo package. For cairo packages we go the next one…

Firefox and Openoffice.org

Check out my screenshots at (Image Sharing) and (Image Sharing).

I have to give credit to 74141 and his excellent rpm at this thread :- Firefox 3.0.1: Enable Using Subpixel Hunting! - openSUSE Forums. This will enable subpixel hinting for FF3.

To enable subpixel hinting for Openoffice.org you need a subpixel-enabled cairo library. I had posted the following instructions at the Mandriva forums (Mandriva Forum >> Firefox 3 terrible fonts) and repeating them verbatim:-

To get the fonts, perform the following steps:-

  1. Grab the Fonts.zip file from the following post:- FedoraForum.org - Ubuntu Hardy’s LCD sub-pixel font rendering in Fedora 9, they have RPMs for 32-bit and 64-bit systems as well.

  2. Untar them to a folder, Fonts.zip, and open the console…login as root.

  3. Remove the stock Opensuse RPMs:-

rpm -e cairo-* --nodeps

  1. Now to install the patched RPMs, navigate to the Fonts/i386 (or x86_64)

rpm -ivh cairo-*

  1. Enable subpixel hinting through your GNOME or KDE desktop manager. I prefer some Microshaft fonts like Tahoma which give perfect rendering

  2. Restart X

Subpixel Hinting for KDE4 (QT4)
You will need the freetype2 package installed first before proceeding. Please refer to my previous entry on “General Subpixel Hinting”

There was a bug in QT4 which detected subpixel hinting at build time and not at runtime. Now due to an official Opensuse policy this was disabled at build time and thus we all had rather bad font rendering when 11.0 came out. However, this was fixed after a bugzilla report was made.

You need to replace the stock qt4 rpms which have subpixel hinting at build time with the ones that detect subpixel hinting at run time. The Qt4.4 repo on the BS has these RPMs. (Subpixel hinting on KDE4-Available now! - openSUSE Forums)

Simply add the Qt4. repo and update your system with the following steps:-

  1. zypper sa -r http://download.opensuse.org/repositories/KDE:/Qt44/openSUSE_11.0/KDE:Qt44.repo

  2. zypper ref

  3. zypper dup

This will install a bunch of qt-x11 and other rpms. Install the same and restart X. You should now have subpixel hinting :slight_smile:

Some more screenshots of my desktop (laptop) with Qt4 and Qt3 apps:-

Image Sharing
Image Sharing

Mods, I would appreciate if you could make this into a sticky. :slight_smile:


Great works!
Hope the developers will make it easier for 11.1, just like it used to be in 10.3.:slight_smile:


Thanks a lot for this HOWTO :slight_smile:

As soon as I saw it I wanted to post some questions and improvements I’ve made but I took too long to find and old post: here in openSUSE Forums and the trick mentioned there, has really made a lot of difference to my Qt and Tcl/Tk apps (take a look at this 2 pictures:

Hintfull http://www.imageno.com/thumbs/20080825/begg4h60lkpd.jpg](http://www.imageno.com/begg4h60lkpdpic.html) and Hintnonehttp://www.imageno.com/thumbs/20080825/aiye2zjax6nh.jpg](http://www.imageno.com/aiye2zjax6nhpic.html).

The trick was to edit /usr/share/fonts-config/suse-hinting.conf.template change this:

 <match target="pattern">
                <edit name="hinting">
                <edit name="hintstyle">
                <edit name="antialias">

to say this:

 <match target="pattern">
                <edit name="hinting">
                <edit name="hintstyle">
                <edit name="antialias">

and run SuSEconfig after that.

As you can see, QCad is a QT aplication and aMSN is a Tcl/Tk app, and the difference is huge with and without. However I cannot see any improvements to FF3, OOo and GNOME apps. (Credit goes to shishirverma) I must also say that I’m using SubpixelHinting from Community and I have a nVidia GC.

A have some questions:

Here in this howto you give the mandriva link to download the files, in the mandriva forum you stand to untar the “fonts.zip” file which contains the binaries located someplace here: but I dont find them ???
Could you tell me please which ones must I download ? (x86_64 here)
Is it ok to follow the mandriva forum link to install all the packages/binaries?
In the fedora forum they are saying that you need the pixman library but I don’ see anything related here… ???

Thanks for your help and Kind Regards

Luis C.

Thank you so much for sharing this information- you’re a star.
Having gleaned all this I know that you are aware of how tedious it is scouring the web etc to get to the bottom of issues of this nature, and it’s something that has been driving me crazy on previous releases and this one. I really appreciate the time you’ve taken to pull it together and present it so clearly- it’s things like this that make this distribution and forum great.


Well I couldn’t get this working, the RPM wouldn’t install and I had to back the changes out. LuisC’s comments go double for me.
Still, I now know the reason for open office, and various other applications looking really awful which might seem like nothing but has been annoying me a disproportionate amount for years now.
I think I might drop 11.0 after all and either try Fedora again (had hardware problems last time) or something new.

Yeah, me neither.

Take a look to this post:

Firefox 3.0.1: Enable Using Subpixel Hunting! - openSUSE Forums

That really worked for me, and the fixed I proposed here stills work for v11.0

Good luck