Enable compiz ati 1100

Hi there,

I use openSUSE 10.3 with KDE and try to enable the compiz-fusion on my notebook acer 3102, ati radeon xpress 1100, i use the lastest ati driver disponible on ati repositore (www2.ati.com) but the xgl dont start.

When i do:
#xgl-switch --enable-xgl
My X dont start…

i enable the 3d on sax2 already but nothing happens too…

i use click install to get the compiz.

When i do simple-ccsm and click on enable this happen:
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:05.0 Class 0300: 1002:5975 (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz (core) - Fatal: No damage extension

The information of:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon Xpress Series
OpenGL version string: 2.1.8201 Release

I try to go in yast> system> sysconfig > desktop> display manager> DISPLAYMANAGER_XSERVER> and change the Xorg to Xgl

but my X dont start after that :frowning:

I enable the AIGLX after try with xgl without success (AIGLX - openSUSE) but i cant enable compiz too :frowning:
then now this is the information of:
#grep Composite /var/log/Xorg.0.log
(**) Extension “Composite” is enabled

Can anyone help me to try use compiz? Thanks so much :slight_smile:

Hi there, my compiz now work well :slight_smile:

i found on archive one post that work to me, the link is that if anyone got the same problem:

[solved] Ati Fglrx 8.43 (aka 7.11) + Aiglx + Compiz Fusion [solved] - openSUSE Forums](http://forums.opensuse.org/archives/sf-archives/archives-software/341744-solved-ati-fglrx-8-43-aka-7-11-aiglx-compiz-fusion-solved.html)