Enable classic mounting in 12.3 (to /media)

Hi All,

I have quite unusual setup, I have external hard drive, formatted to encrypted EXT4, which contains home partition for my work user. In 12.1-12.2 I mounted encrypted drive from session of first user, it was created in /media/Enc, had a symlink to /home/extuser, so I could login with second user (without ending first session, where my audio players and stuff are configured).

Now, everything moved to /var/run/USERNAME/LABEL, and basically my work user cannot access his home anymore.

I found this: udisks but somehow I’m not able to set up those attributes, here’s what I tried:


# /etc/udev/rules.d/71-local.rules
ENV{ID_FS_USAGE}=="filesystem|other|crypto", ENV{UDISKS_FILESYSTEM_SHARED}="1", ATTR{UDISKS_FILESYSTEM_SHARED}="1", ATTRS{UDISKS_FILESYSTEM_SHARED}="1"

But it still mounts everything to /var/run.

Tell me please, how can I enable classic mounting in case device should be shared between multiple users? I do not want to rollback to 12.2 because of this, and I don’t see how can I keep home for one user on removable external storage with new mounting rules.

UDISKS_FILESYSTEM_SHARED was added in post-2.0.91 version while 12.3 has 2.0.0 version. Patch is actually small and self contained, so it makes sense to open bug report as it sounds like regression. Post bug number here.

Otherwise dirty trick is to use the first user name with slash ("/") in it. In this case it will unconditionally mount under /media while this user session is active.

Thank you for fast reply. Here is the bugreport: https://bugzilla.novell.com/show_bug.cgi?id=809837

On 2013-03-17 08:06, Aekold wrote:
> I have quite unusual setup, I have external hard drive, formatted to
> encrypted EXT4, which contains home partition for my work user.

Make appropriate entries for it in ‘/etc/fstab’ and ‘/etc/crypttab’. A
partition that is listed in fstab should be ignored by the desktop
automatics and mounted instead where you specify. You will have to play
with ‘auto’ and ‘nofail’ options.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Hi, all, and apologies for the late follow-up…

Aekold wrote:
>
> arvidjaar;2536555 Wrote:
>> so it makes sense to open bug report as it sounds like regression. Post
>> bug number here.
>>
>
> Thank you for fast reply. Here is the bugreport:
> https://bugzilla.novell.com/show_bug.cgi?id=809837
>
>
For those coming upon this later, I’ve just done a ‘zypper dup’ on my
working box from 12.2 to 12.3 (32-bit; I haven’t yet done an
architecture upgrade) and run headlong into this annoyance.

Following Greg’s mention in
https://bugzilla.novell.com/show_bug.cgi?id=809837#c17, after the distro
upgrade, a reboot, and a final ‘zypper up’, I just added:

ENV{ID_FS_USAGE}==“filesystem|other|crypto”,
ENV{UDISKS_FILESYSTEM_SHARED}=“1”

(one line, space after the comma) to

/etc/udev/rules.d/99-correct-media-mount-point.rules

(which did not previously exist) and then ran

‘udevadm control --reload’

Problem solved.

FWIW, udisks2 here is:

libudisks2-0-2.0.0-5.4.1.i586
udisks2-2.0.0-5.4.1.i586

though I still have:

udisks-1.0.4-11.1.1.i586

installed (apparently), but not in use:

dp45sg:/home/lewis # ps aux | grep udisks
root 3020 0.0 0.1 45936 7380 ? Ssl 15:24 0:15
/usr/lib/udisks2/udisksd --no-debug
lewis 3305 0.0 0.1 48072 5496 ? Sl 15:27 0:01
/usr/lib/gvfs/gvfs-udisks2-volume-monitor

This was the second speedbump I hit, after finding that K3B didn’t want
to find cdrecord (it was apparently confused about wodim beling located
in /usr/bin as well as /usr/bin/X11, and wanted me to choose which one
to use… Grrr…

Anyway, I hope this post helps someone else.

Cheers


Lewis

Lewis G Rosenthal, CNA, CLP, CLE, CWTS, RTRP
Rosenthal & Rosenthal, LLC
visit my IT blog www.2rosenthals.net/wordpress

On 2013-05-15 05:54, Lewis G Rosenthal wrote:
> Hi, all, and apologies for the late follow-up…

Welcome. :slight_smile:

Just one comment:

Please use code tags for printouts and commands. Advanced editor, ‘#’
button. Posting in Code Tags - A Guide

Use them to post things such as the config line to write, so that
formatting is not changed. I believe you are using nntp, so in that case
you write the word “CODE” before and “/CODE” behind, with the quotes
substituted with square brackets. And if you use thunderbird, in order
to avoid line wrap, use “paste as quotation”, it disables line wrap.

More tricks for nntp:

BB Code

(yes, I also use that mount trick you mention :slight_smile: )


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Thanks, Carlos. Unfortunately, using BBCode in an NNTP setting is awkward, at best, as there is no way to preview to check for missing closing tags and such. The beauty of NNTP is plain - really plain - text, and not the “prettified” output in a web interface.

I know you’ve put considerable time and effort into documenting such things, but I normally post from NNTP for a reason, and that is that I don’t like to be bothered with code tags in forums and other such things.

If this is a problem for the forum admins (and while I show as a “newcomer” in these forums, I’ve been active with Novell-sponsored discussion groups since the CompuServe days, in the 1980’s), I understand, and will restrict my contributions to my own blog, where I am able to set the rules as I wish.

Cheers

On 2013-09-22 18:36, Rachelsdad wrote:
>
> robin_listas;2556904 Wrote:
>> On 2013-05-15 05:54, Lewis G Rosenthal wrote:
>>> Hi, all, and apologies for the late follow-up…
>>
>> Welcome. :slight_smile:
>>
>> Just one comment:
>>
>> Please use code tags for printouts and commands. Advanced editor, ‘#’
>> button. ’
>> Posting in Code Tags - A Guide’
>> (http://forums.opensuse.org/showthread.php?t=451526)
>>
>
> Thanks, Carlos. Unfortunately, using BBCode in an NNTP setting is
> awkward, at best, as there is no way to preview to check for missing
> closing tags and such. The beauty of NNTP is plain - really plain -
> text, and not the “prettified” output in a web interface.
>
> I know you’ve put considerable time and effort into documenting such
> things, but I normally post from NNTP for a reason, and that is that I
> don’t like to be bothered with code tags in forums and other such
> things.

I understand, but thousands of users here read via http web forum,
that’s the primary interface. Nntp users are the minority. Yes, hand
typing such codes is a bore, but unless you do, those thousands of users
will not be able to properly read sections that look like code because
their interface interprets things. For example, the colon and slash in a
link gets converted to a smiley.

Thus it is polite of us, nntp users, to use code tags to surround those
sections, even if it is not needed inside nntp.


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Rachelsdad wrote:

> I know you’ve put considerable time and effort into documenting such
> things, but I normally post from NNTP for a reason, and that is that I
> don’t like to be bothered with code tags in forums and other such
> things.
>

Lew, you’re as grumpy as I am but this is simple enough that even I use it:

CODE

Just create a section like this and it disables the word wrap for both the
gui and nntp readers

/CODE

As I said, even I can use that!


Will Honea

On 2013-09-22 22:00, Will Honea wrote:

> Lew, you’re as grumpy as I am but this is simple enough that even I use it:
>
> CODE
> --------
> Just create a section like this and it disables the word wrap for both the
> gui and nntp readers
> --------
> /CODE
>
> As I said, even I can use that!

Almost :slight_smile:

Unfortunately, the gateway does not understand that syntax - look for
yourself at the webside. You need to use brackets.


> https://forums.opensuse.org/english/get-technical-help-here/hardware/484495-enable-classic-mounting-12-3-media.html


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Carlos E. R. wrote:

> On 2013-09-22 22:00, Will Honea wrote:
>
>> Lew, you’re as grumpy as I am but this is simple enough that even I use
>> it:
>>
>> CODE
>> --------
>> Just create a section like this and it disables the word wrap for both
>> the gui and nntp readers
>> --------
>> /CODE
>>
>> As I said, even I can use that!
>
> Almost :slight_smile:
>
> Unfortunately, the gateway does not understand that syntax - look for
> yourself at the webside. You need to use brackets.
>
>


>> https://forums.opensuse.org/english/get-technical-help-here/hardware/484495-enable-classic-mounting-12-3-media.html
> 

>

I’m not sure how the gateway parses the code tags - I’ve seen a wide variety
of formats using the word CODE in various ways that seem to work.

To make this useful: I used a suggested method to get devices mounted
directly mounted under /media as the 12.3 kludge results in the devices
showing up in at least 2 (different) places. I backed out the change when
it appeared that changing the mount point resulted in a real garbage pile in
the /media directory as ejecting/unmounting did not clean up the references
to the removed media.


Will Honea