EmulationStation not working

Hey folks,

Running into an issue with a dependency for EmulationStation on Tumbleweed. I tried to install it but it says that the package manager is unable to satisfy a dependency for libboost_filesystem.so.1.71.0. I do, however, have later packages installed:

localhost:~> zypper se -i libboost*75*
Loading repository data...
Reading installed packages...


S | Name                            | Summary                                          | Type
--+---------------------------------+--------------------------------------------------+--------
i | libboost_date_time1_75_0        | Boost.DateTime runtime library                   | package
i | libboost_filesystem1_75_0       | Boost.Filesystem Runtime Libraries               | package
i | libboost_filesystem1_75_0-devel | Development headers for Boost.Filesystem library | package
i | libboost_headers1_75_0-devel    | Development headers for Boost                    | package
i | libboost_iostreams1_75_0        | Boost.IOStreams Runtime Libraries                | package
i | libboost_locale1_75_0           | Boost::Locale runtime library                    | package
i | libboost_thread1_75_0           | Boost.Thread runtime libraries                   | package

I’m not sure what to do here.

The only reason I am trying EmulationStation is because I haven’t had much luck with RetroArch. I tried building the libretro duckstation core (the Mednafen Beetle PSX HW core is hard to digest for the crappy little mini HTPC he has) but I am running into errors there and figured this might be an easier route to take… It seems I’m hitting a wall no matter what I try.

Sorry to pester twice in one day but I figured I’d ask people more clever than myself for some help.

Hi
The Tumbleweed build is broken hence your error… Unfortunately it needs fixing, I would suggest a bug report since it hasn’t been touched in a few years.

openSUSE:Submitting bug reports - openSUSE

https://build.opensuse.org/package/show/Emulators/EmulationStation
https://build.opensuse.org/package/live_build_log/Emulators/EmulationStation/openSUSE_Tumbleweed/x86_64

Looks like the source for EmulationStation hasn’t been updated for at least 7 years…
https://github.com/Aloshi/EmulationStation

So, I suspect that it’ll be problematic whether it’ll run at all.
Looks like this guy created an openSUSE package around that time
https://pkgs.org/download/EmulationStation

Based on a quick search, RetroArch is generally recommended to do the same thing, is in the openSUSE repos

https://software.opensuse.org/package/retroarch

TSU

Thanks for the replies. https://bugzilla.opensuse.org/show_bug.cgi?id=1183882 is the bug report I’ve filed.

Yes, EmulationStation hasn’t been updated in time but I see other modern distros using/building it without issue.

I am trying to set up RetroArch as well, but here is my problem:

  1. I am using a much older mini HTPC (Zotac ID42-Plus). The thing has a crappy little 1.1GHz Celeron and a GT610 in it.
  2. As a result it struggles with some of the libretro cores for hardware it should -definitely- be able to handle (e.g. Playstation 1) simply because they are not optimized.
  3. I tried building the Duckstation libretro core as it doesn’t exist in the OpenSUSE repos… I ran into a build issue and have no idea how to fix it/get around it.

I am trying to set this thing up for a buddy of mine (got it for him as a bday gift eons ago and we just dusted it off recently, but, it was running OpenSUSE 13.2 and none of the browsers could load half of the websites he uses such as Youtube as a result- also it’s EOL iirc, so none of the repos worked) and making all the emulators/etc work just from one frontend.

Retroarch is great and all… But the Mednafen emulators are hot garbage for optimization. PCSXr, epsxe and Duckstation completely crush it in terms of 1:1 performance on hardware but I’m unable to dig up a core for it that would accomplish this (the only thing that’s close is PCSX-rearmed, but if I recall correctly that is for arm architecture. Won’t work on a little x86 celeron).

I figured the alternative would be to throw Emulationstation on it and set up various emulators manually.

Nope. I’m dense. PCSX-Rearmed runs on x86. Welp, at least we got a bug report out of it.