Empathy not working with MSN

I am using suse 11.2 and I am not able to login to Windows Live protocol (MSN) using empathy. This seems to be caused by a small change in the protocol. There is a simple solution detailed here:

https://bugs.launchpad.net/ubuntu/+source/papyon/+bug/887481/comments/13

The problem is that I don’t know which file is the equivalent to /usr/share/pyshared/papyon/service/description/AB/init.py . Any suggestions?

Am 18.11.2011 09:26, schrieb lasm2000:
>
> I am using suse 11.2 and I am not able to login to Windows Live protocol
> (MSN) using empathy. This seems to be caused by a small change in the
> protocol. There is a simple solution detailed here:
>
> http://tinyurl.com/d72kmyv
>
> The problem is that I don’t know which file is the equivalent to
> /usr/share/pyshared/papyon/service/description/AB/init.py . Any
> suggestions?
>
>
Usual comment 11.2 is end of life and should be upgraded, but that does
not help you in this moment so let us see.
I do not use empathy and msn so I hope a short in the dark is ok for
you. I looked at the bug report you mention and and it refers to papyon.
Can you check as a first step that the papyon package is installed (I
see in 11.4 it has exactly that name) and then run the following command
to see which files it contains


rpm -ql papyon

when you look at this list you should be able to identify where the
equivalent of the
/usr/share/pyshared/papyon/service/description/AB/_init file is on
openSUSE.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Am 18.11.2011 11:15, schrieb Martin Helm:
>


> rpm -ql papyon
> 

> when you look at this list you should be able to identify where the
> equivalent of the
> /usr/share/pyshared/papyon/service/description/AB/_init file is on
> openSUSE.
>
In 11.4 it is this file
/usr/lib/python2.7/site-packages/papyon/service/description/AB/init.py
I think for 11.2 you just need to replace the 2.7 with 2.6 to get the
path on your system.


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

The Empathy not working with MSN problem exists in 12.1 as well. The solution mentioned above of making the following change fixed the issue for me.

Edit /usr/lib/python2.7/site-packages/papyon/service/description/AB/init.py

and make the following change:

url = “http://contacts.msn.com/abservice/abservice.asmx
to this
url = “http://local-bay.contacts.msn.com/abservice/abservice.asmx

I’m using also 12.1 but when is try to change the file it says that since i am not the owner i can not modify the file… even as root user
any help? thanks

i did change the file by typing:
gnomesu gedit /usr/lib/python2.7/site-packages/papyon/service/description/AB/init.py

and then modifying url to: url = “http://local-bay.contacts.msn.com/abservice/abservice.asmx

still MSN messenger protocol is not connecting, it just says connection failed

so after this the only option i had to check was the port, i think i changed it before but i set it up to 1863 and now i am connected…it worked

Am 19.11.2011 17:36, schrieb optimuskx:
> I’m using also 12.1 but when is try to change the file it says that
> since i am not the owner i can not modify the file… even as root
> user any help? thanks
>
That is near to impossible, by the way root is the owner of the file.
You probably typed something wrong, what did you do exactly (best is you
post an exact copy of what you typed including all the output the
terminal gives you).


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Am 19.11.2011 18:26, schrieb optimuskx:
>
> optimuskx;2406398 Wrote:
>> i did change the file by typing:
>> gnomesu gedit
>> /usr/lib/python2.7/site-packages/papyon/service/description/AB/init.py
>>
>>
>> and then modifying url to: url =
>> “http://local-bay.contacts.msn.com/abservice/abservice.asmx
>>
>> still MSN messenger protocol is not connecting, it just says connection
>> failed
>
> so after this the only option i had to check was the port, i think i
> changed it before but i set it up to 1863 and now i am connected…it
> worked
>
>
Glad to hear you solved it :slight_smile:


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

Thanks for your replies. It worked perfectly. By the way, is this going to be distributed to the rest of users as an update fix? I mean, is a very small change but of significant value to the wlm protocol users.

Am 21.11.2011 07:56, schrieb lasm2000:
>
> Thanks for your replies. It worked perfectly. By the way, is this going
> to be distributed to the rest of users as an update fix? I mean, is a
> very small change but of significant value to the wlm protocol users.
>
>
We are not developers but users and I do neither use empathy nor MSN.
I do not know if the packagers are aware of that problem or if it is
already solved upstream. Maybe you can file a bug and the workarounds in
this thread which solves it to show what has to be changed.
https://bugzilla.novell.com
search first if it is already reported - thank you


PC: oS 11.4 (dual boot 12.1) 64 bit | Intel Core i7-2600@3.40GHz | KDE
4.6.0 | GeForce GT 420 | 16GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.7.3 |
nVidia ION | 3GB Ram

I did the exact same thing and I also cannot connect.

I do see that you said that you were able to connect when you set the port to 1863 but this is how mine is set up and yet I still cannot connect.

It just says “connecting” forever and ever … sigh.

Here is an image … maybe I need to change something else:

http://img830.imageshack.us/img830/5807/empathymsntrouble.jpg

Please note I blacked out some stuff in the image but forgot one. Oh well. So you all know my MSN ID now heh

Anyway … Any ideas on how I can maybe fix this?

I couldn’t figure out how to edit my post above so I’m posting again (sorry).

Just wanted to make clear that I’m using openSUSE 12.1 with the gnome desktop.

Also I can log into my MSN/WLM account just fine via Pidgin.

Hey, lads! I’m kinda of a newbie here (be patient, please!).
I’m having the very same problem, although I did exactly what you guys told us to do nothing really changed: I still can’t log in my WLM account.

Any news? Updates?

I wanted to switch back to Empathy today to use gnome-shell features, however I couldn’t get connected to neither GTalk nor MSN via empathy. That py configuration didn’t work either.

Great. Same solution works for me. But I really wonder why this have not been fixed by software distribution.

Cheers,
Uwe

I solved the issue.
Here’s the workaround:

  • Remove your live account.
  • Exit from Empaty
  • Remove telepathy-butterfly
  • logout/login
  • Enter your account again
  • voilà

Finally it works for me, but just when I marked the HTTP METHOD option:

  • Remove your live account.
  • Exit from Empaty
  • Remove telepathy-butterfly
  • logout/login
  • Enter your account again
  • mark the Http Method option

regards,

Gilberto