Emimax EW-7811Un Nano Wifi Adaptor/Intel Pro Wireless 5100 AGN Help Required

Hi,

Hope someone can help as I am going mad trying to get any kind of wireless dongle working in suse or any other distro. same goes for my wireless PCI card. Hardware disabled.

Having been an avid user of Windows for many years i’m perplexed about building drivers etc and wouldn’t know how to start.

I’ve tried lots of distros and finally settled on Suse hoping that by some miracle when I installed it my dongle or PCI card would kick in. Nope, zilch.

My Edimax USB dongle and the PCI wireless card show up but in every distro they say hardware disabled. Try as hard as I can I can’t enable them. Why?

The Edimax has Linux drivers here.
http://www.edimax.com/en/support_detail.php?pd_id=347&pl1_id=&pl2_id=

I tried to make the driver in mint but it failed and was still disabled after typing lots of code into terminal.

How do I install or make them? I’m lost with terminal speak so if someone can help but keep it simple then that would be great.

:’(

Chris

Hi
Sure it’s not recognized but may be either hard or soft blocked?

As root user run;


zypper in rfkill
rfkill list

As Malcolm has already suggested, your device may already be supported. Your device may well utilise a Realtek chipset. check with

lsusb
usb-devices
  • The last command will show if there is an active driver associated with your usb hardware

Hi,

How do I get root from terminal. Sorry noob question!

Results of lsusb below.

Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Results of usb-devices

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=7392 ProdID=7811 Rev=02.00
S: Manufacturer=Realtek
S: Product=802.11n WLAN Adapter
S: SerialNumber=00e04c000001
C: #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 4 Cls=ff(vend.) Sub=ff Prot=ff Driver=rtl8192cu

Thanks

As thought it is a Realtek device, and the ‘rtl8192cu’ driver is active.

Now check if the unit is soft-blocked (as Malcolm mentioned already)

You can become root with

su -

BTW, don’t forget to read the wireless stickies

https://forums.opensuse.org/forumdisplay.php/676-Wireless

They have useful information for diagnostics etc :slight_smile:

Hi,

Here’s what it returned.

0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: yes
Hard blocked: yes
1: phy1: Wireless LAN
Soft blocked: no
Hard blocked: yes
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Kind Regards

Okay, you have two wireless devices present - one of which is enabled. The other is physically turned off. What is reported by the following?

/sbin/ifconfig
 /usr/sbin/iwconfig

If a wireless device is reported, you should try configuring via YaST. There you can elect to use Network Manager.

https://activedoc.opensuse.org/book/opensuse-reference/chapter-25-using-networkmanager

Once Network Manager is enabled, you can proceed to configuring your wireless device for your network.

Hi,

\sbin\ifconfig reports:

enp0s25 Link encap:Ethernet HWaddr 00:1C:25:98:05:09
inet addr:xxx.xxx.x.xx Bcast:xxx.xxx.x.xxx Mask:255.255.255.0
inet6 addr: fe80::21c:25ff:fe98:509/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:425681 errors:0 dropped:0 overruns:0 frame:0
TX packets:247984 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:605066456 (577.0 Mb) TX bytes:19900152 (18.9 Mb)
Interrupt:20 Memory:fc000000-fc020000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:246 errors:0 dropped:0 overruns:0 frame:0
TX packets:246 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:19820 (19.3 Kb) TX bytes:19820 (19.3 Kb)

/usr/sbin/iwconfig reports:

enp0s25 no wireless extensions.

lo no wireless extensions.

wlp3s0 IEEE 802.11abgn ESSID off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr off Fragment thr off
Encryption key off
Power Management off

wlp0s26f7u1 IEEE 802.11bgn ESSID off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr off
Encryption key off
Power Management on

Looks like zilch has been picked up to me but i’m no expert.

Kind Regards

Please enclose output within

[/CO..] tags when replying. It makes for easier reading. (Refer to the '#' button in the editor).

Anyway, the wlp3s0 and wlp0s26f7u1 wireless devices are both reported, with the latter being active (but not yet associated with a wireless network). So now you should try configuring the network device via YaST as explained before. If you set the network devices to use Network Manager, then proceed with connecting to your wireless AP using NM.

Nope. Don’t understand anything you have said. I’m being honest with you. Windows is over bloated and slow. Linux is fast but a god **** pain in the arse to get wireless dongle working.

Please explain in simpleton terms what you mean. Why use different network managers? I’m not bothered about which one I use just want to to connect to the net.

Please could you explain step by step?

Do I need to input ip, subset mask etc. I have no idea apart from IP what that means. Any dongles work out of the box?

Kind Regards

Start YaST (the openSUSE config utility) and navigate as follows

YaST >> Network Devices >> Network Settings, under ‘Global Options’ select ‘User Controlled with NetworkManager’

When you restart your desktop, you should be able to configure using the NM graphical utility. (Gnome and KDE use different implementations of this, but both are essentially the same).

Do I need to input ip, subset mask etc. I have no idea apart from IP what that means.

You can generally use ‘Automatic’ which allows the router to use DHCP to configure.

Any dongles work out of the box?

Yes, including the one you’ve got (based on the output you’ve provided). However, you still need to go through the configuration steps first, otherwise how will the wireless device know which wireless network it should try to connect with, and the authentication credentials etc.

BTW, all that I wrote in this last post is described in the activedoc link I provided. You just have to take the time to read and learn. :slight_smile:

As your helping me I obviously will do as you instruct but I think it’s more complicated than what you are thinking.

OK what ive done is:

enter YAST
Clicked on network settings
Global settings
User Controlled with network manager was already selected anyway.
Clicked on OK.
Rebooted and nothing is different
Tried same method, looked at overview in network settings and all of the options are greyed out.

Normal?

Hi
You need to be using the Network Manager which is part of your desktop, not YaST now that it’s set…

What desktop environment are you using?

Also I would unplug the first card (the one that said it was blocked in the rfkill output), also disconnect the ethernet cable…

No, it’s just unfamiliar to you. Don’t worry, it sounds like you’re making progress. :slight_smile:

OK what ive done is:

enter YAST
Clicked on network settings
Global settings
User Controlled with network manager was already selected anyway.
Clicked on OK.
Rebooted and nothing is different
Tried same method, looked at overview in network settings and all of the options are greyed out.

Normal?

The YaST config is as required then. Now you need to move on to connecting via NetworkManager. As Malcolm has mentioned, tell us which desktop environment you’re using.

Hi,

I am using the second choice on installation. I think it’s KDE.

OK. Here’s what I have done.

Gone to YAST control centre.
Clicked on network devices
Network Settings
Global Settings
Clicked on traditional method with ifup
Applied

The blue light on the dongle has come on.

When I click on the adaptor in overview it’s not connected.

I could be in the wrong area but at least the blue light has come one.

I can’t disconnect the second card as it’s in the laptop and not a dongle as per your comment.

Where do I go from here. Where is network manager or is that what i’m using?

Kind Regards

No, stay with NetworkManager.

Where do I go from here. Where is network manager or is that what i’m using?

For KDE, you probably need to add the ‘Unlock Widgets’ and add the ‘Network Management’ widget. (See the ‘cashew’ icon on the desktop or system tray.)