Emerald doesn't work :(

I only get messed up borders, or no borders. I tried uninstalling/re-installing compiz and emerald, and also removing all the settings (that I could find), but it still doesn’t seem to run. I get the default SUSE decorations, but on boot they are all grey and some parts are missing.

SUSE 11, under KDE3.


Some questions:

Which video card are you using?
Do the normal compiz borders work and is it only emerald bugging?
Have you also installed the emerald-themes package?

What happens when you open a terminal console and enter 'emerald --replace & ’ ?

Thanks for the reply Magic31.

To answer your questions:

  1. Video card = Nvidia 8400gs m (laptop), using the repo supplied Nvidia driver, all my openGL games work ok.

  2. The “normal” borders sort of work, but I get white/grey ones on login, and sometimes they are corrupt and half missing! If I do a “killall compiz” and reload it, they come back to the default openSUSE green ones. Well, sometimes they do.

  3. Yes emerald-themes is installed. Here’s a list of everything compiz related if that helps:


  1. emerald --replace & actually worked the 4th time! It loaded the correct decorations :). The first time it gave me no borders, the second time it gave me the corrupt white/grey ones, third time no borders. Then I did a killall emerald, and the last time it worked perfectly.

I was having the same problem before I removed all the Compiz stuff and replaced it. The Emerald borders never load on boot or compiz first run. I have to kill it and reload it several times :(. I was hoping a re-install would fix it, but it didn’t.

I also tried the latest version of compiz from buildservice-X11:XGL, but still the same thing.

It’s very odd.

well that’s odd!

When I close the term that I ran emerald --replace & in, the borders vanish!

I thought using the “&” made it run in the background?

Could answer you, but unfortunately your screen-name & logo offend me.

Well good for you, I’m scared of men who wear funny hats and dubious moustaches, works out quite well all round :smiley:

To make Emerald work when you start your computer in (KDE):

  1. if the compiz did’t work when the KDE boot:

    >> for [KDE3.x] go to (KDE Control Center) -> KDE Components -> Session Manager -> compiz

    >> and for [KDE4] (KDE Configure Desktop) -> Advanced -> Session Manager -> Window Manager -> Compiz

  2. after that we need Emerald work:
    go to (ccsm) → decoration → commandline write → (emerald --replace)

  3. and as a normal user write this command:

echo "USE_EMERALD=yes" >> ~/.config/compiz/compiz-manager

I hope I understand what you need.

Thank you linuxarabic,
Your advice worked for me.
I’ve been using Ubuntu Gnome for two years and wanted to give SUSE 11.0 w/KDE 4 a try.
I loaded compiz-fusion from the links in the wiki, but was having the same problems as the first poster.
Thanks again,

I ran into the same thing with my Emerald. I would run it in a term and when I closed the term windown I would loose my borders. I then did Emerald --replace &. This would kick me back to a prompt and at that time I could close the term window and everything was fine even after restart.