Elisa Player not working

Elisa Player not running giving the bellow error

“Devang-Linux:~ # elisa
Launcher core version: 0.5.28
/usr/lib/python2.6/site-packages/twisted/internet/_sslverify.py:4: DeprecationWarning: the md5 module is deprecated; use hashlib instead
import itertools, md5
Current core version: 0.5.28
/usr/lib/python2.6/site-packages/elisa/core/utils/classinit.py:34: UserWarning: ClassInitMeta class is deprecated
warn(“ClassInitMeta class is deprecated”)
/usr/lib/python2.6/site-packages/twisted/python/filepath.py:12: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
import sha
/usr/bin/python: symbol lookup error: /usr/lib/python2.6/site-packages/gst-0.10/gst/_gst.so: undefined symbol: gst_structure_change_type_get_type”

Need help solving this

I had the same problem with several python application. To fix it I had to downgrade the package python-gstreamer-0_10 (which was from Packman) to the 11.1 repo’s version.