Elantech Touchpad


I’ve got Lenovo G550 laptop with Elantech touchpad.
Unfortunately for me, SUSE detects it like PS/2 mouse so I can’t edit its settings in gpointing-device-settings and - my main problem - can’t use touchpad scroll.

I’ve found some advice here: Linux On My Samsung • View topic - [HOWTO] Elantech touchpad working right on Samsung R540 JT01 - that I should write options “psmouse force_elantech=1” somewhere, but these steps don’t help.

What should I do to force SUSE to detect my touchpad correctly?

Hi levne

What is reported by the following command?

cat /proc/bus/input/devices

Just post the touchpad related output if possible

There was a bug report concerning elantech touchpads, but it seems to have been resolved:
(You may have a different issue though).

I have one too. In GNOME 3 there’s no problem, I can configure 2-finger scrolling and tapping. In KDE 4.7 it can be configured as well.

A solution for you may be to add the options needed in /etc/X11/xorg.conf.d/50-synaptics.conf which worked for me in the past. Just google on “xorg tapping” and you should find the proper options. A bit advantage of this method is that it works systemwide.

If I am not mistaken, the output is

I: Bus=0011 Vendor=0002 Product=0001 Version=0000
N: Name=“PS/2 Generic Mouse”
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event6
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

Knurpht, I’ve tried different options in /etc/X11/xorg.conf.d/50-synaptics.conf but it didn’t help.
Could you please post here your 50-synaptics.conf?

Can anyone help me? How to fet it work?

I also have an Elantech touchpad on my Samsung. On 11.4 I had the same problem. I’m now using 12.1 and it is detected and working correctly. I assume it is because of the newer kernel. You could try downloading a live 12.1 cd and see if it works on that.