Elantech Touchpad Stopped Working

I installed OpenSuse 12.3 last week and everything has been working. But today my touch pad stopped working.
I had been using a mouse part of the time so I toggle the touch pad off and on(to stop moving the pointer while typing) by using Fn+F10.
Now for some reason that key combination is doing nothing.
I can use the track pad on the login screen but stops shortly after that.
I have tried logging into different desktop environments, but I still have no track pad there either.
xinput list

Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=12   [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ WebCam SCB-1100N                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

I cant think of what I might have done. There may have been some updates this morning.
I just logged out and found that the track pad wasn’t working on the log in screen, so I tried Fn+F10 and it started working. Then after logging in, it stopped again
Any sugestions?

I just created another user, and the touch pad is working there.

Press Alt-F2 and enter

synaptiks

After starting synaptiks will be accessible from the systemtray’s triangle. Double clicking it opens the synaptiks configuration.

“Touchpad on” is ticked, but it still is not working. I tried the Synaptiks short cut for turning it on but still nothing.

I forgot to mention that I’m using OpenSuse 12.3 with KDE 4.10

Please read about synclient from another thread - http://forums.opensuse.org/english/get-technical-help-here/laptop/483753-keyboard-shortcut-disables-touchpad-keyboard.html#post2536226

Thanks Romanator. Still not working.
No error messages messages… and no change.

No error messages messages… and no change.

Please check if you have mtrack installed:
|x11-input-mtrack - An Xorg driver for multitouch trackpads
|
|

Ok, this is strange. x11-input-mtrackwas not installed. I installed it and rebooted. I got this message when the KDE desktop loaded.

  No touchpad was found in this system. If the system has a touchpad, please make sure that the synaptics driver is properly installed and configured. 

 If your touchpad is not found, though the driver is installed and configured correctly, please compile detailed information about your touchpad hardware and report this issue to the issue tracker](https://github.com/lunaryorn/synaptiks/issues).

But now I can use the trackpad. Synaptiks gives me the same message as above.
Although I can use the trackpad, it’s feels a bit sluggish when using 2 fingers to scroll and a bit too sensitive when moving the pointer.
Fn+F10 will enable/disable the trackpad, but I don’t get the KDE notification like before.
Anyhow, its better than before.

Aha! That is great news. I don’t understand why it wasn’t included for your installation. Most likely because it is used as an enhancement rather than a “must install” package option.

Now you can add a “Device section” in /etc/X11/xorg.conf.d/50-device.conf and tweak the performance of your input devices. Check the Gentoo and Archwiki site. One of them has an older copy of a xorg.conf file. I would edit out the “Options” section that do not pertain to your laptop.