EFI boot with traces of GUID partition table wanting to dual boot

Hey-all. So I am for the first time considering using a UNIX platform for long term but I still need to have windows apps for school- word, access ect. I have chosen openSUSE! Hurray.

So I found this problem to be rather unique so I couldn’t find a solution (easily) on google. I need someone who knows what they are doing or a program.

I am looking to dual boot but-
I have OEM windows 8 machine except I have re-downloaded a clean version of windows. It wouldn’t download in UEFI, it would only download in CSM legacy BIOS. I thought, what the heck, go for it. Man, was I wrong. All dual boot options will not recognize windows 8 because, I suspect, it is in CSM partition table but my GUID table still exists.

Solutions? Work-arounds? Resources?

Here is some information;

partition table viewed on windows disk management-
(C:), simple, basic, NTFS, Primary, BOOT/crash dump/primary partition, 197.89GB (may re-size), 60% free
(f:), system reserve, NTFS (probably should be something else? suggestions?), System/ACTIVE/PRIMARY PARTITION, 100mb, 56% free

Thanks for your time, whether you can help or not. Really appreciate and value everyone’s time on here :slight_smile:

Best would be to install windows as UEFI. You might need to contact the vendor for the computer to see how to get the install software.

The other alternative is to repartition your disk in non-GPT format.

The way that I have done this, is to run “gdisk” and use the “z” command to zap the GUID partition table. But doing that might mess up your opensuse install.

There might be utilities out there to convert a GPT disk to traditional MBR without damaging partitions.

Assuming that you switch the disk to MBR partitioning and preserve opensuse, there’s the question of booting it. You would need to switch to “grub2” instead of “grub2-efi”.

Thank you. I didn’t know about the commands to gdisk, very helpful. While, I’d love to boot in UEFI I can’t afford my manufactures (toshiba) recovery disk, nor can I find the correct files for UEFI OEM windows 8 but I found a post about my problem and I think it will work. The post is below. About the booting- when do I change grub-2 to efi before install or after?

Unrelated question: will windows try and delete my linux partitions when I choose to boot using windows?


You can change any time but note that it is less trouble to change at install Just boot the install media in EFI mode and it will defalt. Note that mixing MBR and GPT partitions in theory can be done but may have difficulties. best to stick to one method or the other. never mix never worry.

Thank you, I’ve decided unless there is more input to nuke GPT partition table. I don’t want to mix. Unless you mean mixing UEFI capable machines with MBR partition tables? I don’t know, I’m kinda new to the subject. I’m booting in CSM now, and choosing MBR partitions so I think that should be good, right?

No most EFI BIOS have a legacy mode that uses MBR partitioning. Boot the installer in MBR/legacy mode and you should get just a normal grub2 install. Take care note all partitions and their start and stop values. Nuking a partition table will lose all that information unless there is also a valid MBR table to take up the slack. You should get the partitions back when you define the partitions again just use the values for origianl partitions for new ones plus any for the new OS.


So far I have deleted GPT partition table and I have openSUSE installed. I’m using easy BCD for dual booting both windows 8 and openSUSE. When I load my computer it allows me to choose which OS I want to use. My windows 8 OS still works when I click on it BUT I get a small rectangular blue box on the top right. I’ve tried finding a solution to this bug but I haven’t come across anything on google.

Here is a picture, sadly you won’t see any details because of the terrible quality but really it is just a box with smaller boxes.


Some information

computer spec:
AMD E1-1200 APU with Radeon™ HD Graphics 1.40 GHz

partition set-up (ofcourse you can’t see all of the info. because I haven’t booted into openSUSE yet.

it is very unclear to me why you would just delete the partition table. I assume you are trying to move to a MBR boot from an EFI boot. Obviously Win 8 does not like that. Maybe someone on a Windows board might know. And I’m not sure that BCD works at all with EFI and openSUSE seem to remember other trying it and it no longer was a solution

any way you have too many partition to simply zap GPT partition table MBR only supports 4 primary of which one can be an extended which can then have many logical. In GPT there is no extended or logical partitions but you can have a lot of primary. We need to see the current partition layout to get a clue boot to a live Linux and show us fdisk -l (that is a lower case L not a one)

I deleted the partition table because I was already using MBR but the GPT table still exists so it confuses about all linux installations to not recognize windows 8. I was using MBR because I crashed my computer one day and a EFI version from OEM was the only one I can find.

I am booted in windows 8 OEM from MBR so there is no need to have a GPT table. I took it off and windows 8 still works fine. Unless I am not understanding correctly.

I don’t understand what you mean about not having enough partitions to dual boot on MBR. Anyways, I am redoing my steps except I will change around the boot options to grub, if it doesn’t work then I will boot into another live CD.

(Sorry, I am not understanding, I’m kinda new to this)

SOLVED! It probably was easyBCD that was causing the error. I can’t say for sure because I did the process again with a re-downloaded iso. EasyBCD would not open at all in windows 8 and openSUSE was not showing up in bios after 2 times I started my computer. The program is buggy with my set-up.

So I let grub2 handle the booting process and tested both windows 8 and openSUSE out, hopefully nothing goes wrong after this point.

I think easyBCD stopped working with EFI BIOS

OK if you go to MBR format it only supports 4 primary partition of which one can be an extended which can hold many logical partitions. In essence if you have more then 4 partitions in GPT they don’t map directly to MBR partitioning scheme. So preserving partitions when moving between MBR and GPT take some doing and is not in any case automagical

Okay, sorry but your confusing me. I had nothing on GPT partitioning table, everything was on MBR except the table itself, no information. I already deleted it and because of that it was very easy to do. And now i have dual boot both on MBR.

My windows 8 is not the one I got from toshiba, it’s a download that only excepts EFI capable machines, not UEFI.