edit the "on" to the /usr/share/X11/xorg.conf.d/11-evdev.conf file

my notebook (akoya e4254 the touchpad and clickpad mouse is not working at all.

here in this path i have the both files:
see the path;


    /etc/X11/xorg.conf.d/

i have

[martin@martin-pc xorg.conf.d]$ ls -l
insgesamt 4


-rw-r--r-- 1 root root 266 24. Jul 23:52 00-keyboard.conf
-rw-r--r-- 1 root root   0 26. Jul 22:38 30-touchpad.conf

[martin@martin-pc xorg.conf.d]$

question: how could I edit the “on” to the /usr/share/X11/xorg.conf.d/11-evdev.conf file?


   

    Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    EndSection

I have read on a lot of threads about this issue.

If editing this file /usr/share/X11/xorg.conf.d/11-evdev.conf is ok, what is the best method?

  1. sudo nano /usr/share/X11/xorg.conf.d/11-evdev.conf
  2. sudo gedit /usr/share/X11/xorg.conf.d/11-evdev.conf
  3. from files simply follow path to -evdev.conf file and edit and save

by the way : the file resides in /usr/share/X11/xorg.conf.d/

it is there … the 11-evdev.conf

Doesn’r matter in which way the file is edited.

I usually open “file manager-super user mode”, follow the path “/etc/X11/xorg.conf.d/”, right click on the file “11-evdev.conf” and choose “open with kate” or “kwrite” and edit, and save

hello dear both

many thanks for the continued support. i did the following - and added the file:

  • i have added the 11-evdev.conf file

i restarted the notebook - but the mouse and the clickpad only functions with the wire-Mouse.


[martin@martin-pc xorg.conf.d]$ su
Passwort: 
[martin-pc xorg.conf.d]# for i in /etc/X11/xorg.conf.d/*; do printf "$i:
%s
" "$(<$i)"; done
/etc/X11/xorg.conf.d/00-keyboard.conf:
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
EndSection
/etc/X11/xorg.conf.d/11-evdev.conf:
Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "evdev"
EndSection
/etc/X11/xorg.conf.d/30-touchpad.conf:
Section "InputClass"
    Identifier "touchpad"
    Driver "libinput"
    MatchIsTouchpad "on"
    Option "Tapping" "on"
    Option "TappingButtonMap" "lmr"
EndSection
[martin-pc xorg.conf.d]#
 

well - what can we do now - did i do something wrong?

i look forward to hear from you

regards

I haven’t read this thread from the beginning, but just noted that you’re attempting to configure for evdev. You should know that by default libinput has largely superseded evdev, so if you’re using Xorg then it is probably libinput configuration that is needed.

In general, the underlying Xorg input driver can be found using something like

grep "Using input driver" /var/log/Xorg.0.log

Ref:
https://wiki.archlinux.org/index.php/Libinput