edit fstab in tumbleweed

Hi guys,
it looks like I have a dead drive somewhere, but I cannot seem to get to fstab after using my usb install media to boot to rescue system
I cannot post verbaum but it looks similar to:

joe /etc/fstab
/dev/root /ext 2 defaults 0 0
proc/proc proc defaults 0 0
sysfs/sys sysfs defaults 0 0
devpts/root /ext 2 defaults 0 0
I realized its likely using the rescue live image
so I tried to mount sda (which is my boot drive)
mounrt /dev/sda & 1-4
and I got
mount.bin .dev sda# cant find in /etc/fstab

any help?
thansk John Kilbert

I can’t be sure as I have not done this for years
But I prefer accessing drives and partitions with a LiveCD (usually Ubuntu) or Parted Magic

The problem obviously is that mount doesn’t know where it should mount it to, because /dev/sda is not listed in (the LiveCD’s) fstab.
You need to specify the mountpoint.

Also, you probably rather want to mount /dev/sda1, which is the first partition on /dev/sda, whereas /dev/sda is the whole disk.

So e.g.:

mount /dev/sda1 /mnt

should make the first partition on /dev/sda show up under /mnt.

For further help, please post the output of “fdisk -l”.

I guess the OP better first tries to find out what is what. E.g. /dev/sda1 could be a swap partition.

Though the mount will just fail in that case, or if he mounts the wrong partition he will just not find the fstab he wants to edit.

In any case, “fdisk -l” should give the necessary information, that’s why I asked for it. :wink:

Well, as I see it (but who believes me), he does not really want to edit /etc/fstab of his system. He seems (but I admit that his post is full of uncertainties and nonsense) to run a life/rescue system and executes that mistyped mount command from it. Thus the life/rescue system tries to find missing information in the /etc/fstab of the life/rescue system. It can’t find any and thus complains about the /etc/fstab of the life/rescue system. Not about the /etc/fstab of the /dev/sda based system.

I have the idea that the title of this thread belongs to the category "asking for the step in the (in this case wrong) path instead of asking about the problem. We have some luck in that he says

it looks like I have a dead drive somewhere

I suggest to the OP to make a more precise and extensive description about his real problem that tells us more then “dead drive somwhere”.

Just my two cents.

As I understand it, his system does not boot anymore because some possibly dead drive is mounted from fstab.
So he wants to “repair” that by editing the system’s /etc/fstab from a Live/Rescue USB stick.

But I agree that the original post is not really clear…

I went through this situation a few years ago with an Ubuntu setup with a failed non-primary drive. One of the steps outline in


may work, but I haven’t tried it with TW.

You are still talking about a solution you found somewhere for a problem we have no description of except “dead drive somewhere”.

No information at all. Which disk of your many disks in the system? What is on the disk? How did you come to the conclusion that it failed?

Really nice thread.
Someone asked a question few hour ago (16 if I am right) and a lot of people of good faith try to guess what wanted to say.
I hope I am not misunderstood.