edge scrolling

I have updated my Tumbleweed installation to Gnome 3.20. (hp pavilion g7 laptop)
But there is no longer the option in “mouse/touchpad” to select 2 finger or edge scrolling.
I am used to edge scrolling, so is there an other way to enable this function?

I tried it with dconf-editor (/org/gnome/settings-daemon/peripherals/)
But no touchpad was listed there.

Hi, I don’t have the latest TW yet, but on my Gnome:Next LiveCD, based on TW 20160321, I see in dconf editor:

> org > gnome > desktop > peripherals > touchpad > edge-scrolling-enabled >>> true

and apparently the default is “true”.
So it should be possible to add that key in Gnome 3.20 even if the current TW config doesn’t show it.


Thanks for you’re answer

Maybe I’m doing it wrong, but I have added the key, but Dconf-editor is telling me that there is “No Schema Found”

The description says (when you select the key):

“No schema available. Dconf Editor can find a schema associated with this key.
The application that installed this key may have been removed, may have stop the use of this key,
or may use a relocatable scheme for defining its keys.”

Unless they tweaked something in the last TW, the gschema involved should be/usr/share/glib-2.0/schemas/org.gnome.desktop.peripherals.gschema.xml
installed by gsettings-desktop-schemas
The relevant section should read:

<schema gettext-domain="gsettings-desktop-schemas" id="org.gnome.desktop.peripherals.touchpad" path="/org/gnome/desktop/peripherals/touchpad/">
    <key name="edge-scrolling-enabled" type="b">
      <summary>Whether edge scrolling is enabled</summary>
      <description>When disabled, touchpads that only support edge scrolling (and not 2-finger scrolling) will have that feature disabled.</description>

In a terminal you should be able to do the following:

linux@nohostname:~> gsettings list-keys org.gnome.desktop.peripherals.touchpad
linux@nohostname:~> gsettings get org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled
linux@nohostname:~> gsettings set org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled true

See “man gsettings” for other options.

Hi, got back on Leap, Gnome 3.16, and here things are a bit different…

~> gsettings list-keys org.gnome.desktop.peripherals.touchpad
~> gsettings get org.gnome.desktop.peripherals.touchpad scroll-method

So something has changed indeed in-between and maybe an old schema file slipped in…
If so, you should file a bug report to alert TW maintainers.

Looks like the schema has changed for Gnome 3.20, also check that xf86-input-libinput is installed and if edge-scrolling is true all should be good…?

Thanks for you’re patience and you’re answers.

xf86-input-libinput is installed.

when I go to my terminal:

jsteen@linux-i7ij:~> gsettings get org.gnome.desktop.peripherals.touchpad edge-scrolling-enabled

so it should be enabled

If i look in Dconf-editor, the key “scroll-method” has the value ‘edge-scrolling’
But also “No schema found”
So edge-scrolling is still not working

It seems that the settings from the 3.18 version (e.g. “scroll-method”) are still in place and maybe interfere with the new Gnome 3.20 settings (e.g. “edge-scrolling-enabled”).
Check with a new user, if scrolling is as expected you may choose to rename (or delete) /home/jsteen/.config/dconf/user and rebuild your Gnome preferences from scratch.

Still no success.
I’m going to make a bug rapport.

for more info:

Hi, I had the same problem and I registered just to tell you about a workaround I learned from Fedora.

Follow these steps and you can get your edge-scrolling to work:

  1. Install " xinput "

  2. logout and login to Gnome 3.20 again.

  3. open a terminal and run: **xinput list
    ** - look for your touchpad and remember the ID. On my laptop with an Elantech touchpad the ID is 14.

  4. create a file called **edge-scroll-workaround.desktop in /usr/share/applications/ **for every user or for just 1 user in **~/.local/share/applications/ **

  5. with your favorite texteditor place the following in that file:
    **[Desktop Entry]
    Name=Edge scroll workaround
    Exec=/usr/bin/xinput set-prop 14 “libinput Scroll Method Enabled” 0, 1, 0 ** // Replace 14 with the ID of your touchpad! **

6) If you don’t have gnome-tweak-tool installed, do so and run it.
7) In Gnome-tweak-tool go to: **Startup Applications
8) press + and search for edge-scroll-workaround **and add it.
9) logout and log in again.
10) pro-tip: you might want to disable Natural Scrolling for the Touchpad in **‘Settings’ **- **‘Mouse and Touchpad’

Happy scrolling!**

(Most of these steps are straight from the Fedora forum, I adopted it a slight bit for OpenSuSE Thumbleweed, the original post can be found here: ****https://ask.fedoraproject.org/en/question/89443/how-to-enable-touchpad-edge-scrolling/ )

FYI, the last line in the .desktop file (name en_us) can safely be omitted.

Thanks for this info.