ecryptfs-setup-private script fails

The script fails at the final stage with

Testing mount/write/umount/read…
mount: Operation not permitted
ERROR: Could not mount private ecryptfs directory

It looks like users don’t have the permissions to mount.ecryptfs : is there a simple way to permit this?

Rather old thread, but this is still an issue on openSUSE 11.4 (x86_64). Solution is written here:

If you want to have a Private folder mounted and decrypted on login the simplest solution is to use the ecryptfs-setup-private command. In order for this to work under openSUSE you must first execute the following command:

$ sudo chmod +s /sbin/mount.ecryptfs_private

Here are the most popular,most stylish, Product quality,commodity price is absolutely,
All commodity free shipping and quantity discount, fashion handbag, Sunglass on sale,
handbag wholesale,
Sunglass wholesale,
commodity brands such as :
Oakley/Rayban/cartier/Armani/CARRERA/Tom/ED Hardy/BVLGARI) etc,
quick to give your lover and friend buy gift !
welcome to: === tidebase Outlet,Free Shipping On tidebase Online ===

I recently switched do openSUSE 12.1 and I tried to setup an encrypted directory using ecryptfs-setup-private and failed miserably…

I did the above (set permissions), which let me mount the directory. But I’ve been getting a message that the ecryptfs kernel module is not loaded. A quick modprobe helped and I could mount ~/Private manually. But I want it to mount automatically on login.

I added ecryptfs to modules loaded on boot in /etc/sysconfig/kernel, no change. I read on the net that there is also a pam module needed so I looked into yast and installed pam_mount… still nothing and I still get the message that the kernel module is not loaded :-/. I read on a forum about Archlinux that pam needs some more config done in /etc/pam.d/kde (I use KDE), but this file doesn’t exist :-/.

I’ve been using Debian and later Kubuntu for the past 5 or more years and I’m really puzzled with this - can anyone help me?

Once during boot (when fsck dropped to the console to check the drives) I noticed a message: unable to load ecryptfs - unrecognized name or option in module, see dmesg (or sth similar, don’t remember now). I checked dmesg but no info about ecryptfs was to be found :-(.

Since this is bugging me, i opened a bug report: - you may probably want to vote for this.