eclipse package broken link 11.1 x86

I have installed the eclipse platform in openSuse 11.1 in x86 architecture.
When I try to install a plugin eclipse error log says:
Unable to access file “plugins/org.eclipse.core.filesystem.linux.x86_64_1.0.100.v20080604-1400.jar!META-INF/MANIFEST.MF”.

When I inspect the eclipse package under /usr I find that the file in question vis:
is a link to a similarly named file under /usr/lib64/eclipse/plugins/. My system, being an x86 system, does not have such a directory so the link goes nowhere.

Under /usr/lib/eclipse/plugins/ I find a file called org.eclipse.core.filesystem.linux.x86_1.2.0.v20080604-1400.jar which could be an alternative link destination.

Can anyone help?

For those who end up here, I had a similar problem. Or perhaps the same and there’s another log file I don’t know about.

“Help > Software Updates…” always says

“Cannot launch the update UI. This installation has not been properly configured for software updates”
This is “friendly” speak for the real diagnostic in the doubly hidden file ~/workspace/.metadata/.log

!ENTRY org.eclipse.equinox.p2.ui.sdk 2 0 2009-07-08 23:44:32.752
!MESSAGE Could not locate the running profile instance

Don’t ask me what a profile instance is or how to make one (and good luck finding out). The solution is to forget about opensuse’s package and just download and extract a .tar.gz archive directly from It runs fine out of the box. There is quite some difference between /usr/share/eclipse/configuration/config.ini as installed by the opensuse package and the config.ini supplied by directly. I tried to no avail to fix opensuse’s config.ini. Looking at pblewis’s post now that would never have worked.