Eclipse Juno problems in 12.3 - undefined symbol: g_simple_proxy_resolver_new

I’ve just upgraded to 12.3 (32-bit, tumbleweed), and installed eclipse-java-juno-SR2-linux-gtk.tar.gz (32-bit).

Eclipse will run for a while, then disappears when I perform some action, though it’s not very predictable what causes it. Running from a console, the following error appears:

/home/ulbin/eclipse-4.2.2/eclipse: symbol lookup error: /usr/lib/gio/modules/ undefined symbol: g_simple_proxy_resolver_new

The only similar fault I could find was in ArchLinux:, where they think it is a glib issue.

Is anyone else getting this?

no need to install. Just extract the file and run the executable
I downloaded this (eclipse-jee-juno-SR1-linux-gtk-x86_64.tar.gz). Extracted using file roller and double click on “eclipse” executable and it works and i use openJDK from the repos.

$zypper se -s -i *jdk*
Loading repository data...
Reading installed packages...

S | Name               | Type    | Version       | Arch   | Repository            
i | java-1_7_0-openjdk | package | | x86_64 | Main Update Repository

Yes, sorry, I didn’t mean I tried to install a package - as far as I know, there isn’t an opensuse Eclipse package? I just did as you said: expanded the tgz and then ran the eclipse. I’ve been working with Eclipse like this for years, but sometimes you do get instabilities at distro upgrade times. The only reason I upgraded to Juno is that the old 3.7.2 I had wouldn’t run with 12.3 either (similar problem with unknown symbols).

And I use the opensuse 1.7.0 openjdk, as you do too.


the only time i got those error were when i tried use 32 bit eclipse on 64 bit machine
what does your arch say? Mine says.


I am running a 32-bit OS and Eclipse on a 64-bit machine. So “arch” reports i686, but it’s running on an i5 Lenovo T420.

But this combination should work, presumably?

Regardless of underlying hardware, it is installed OS that counts. It is just the the OS cannot harness the full capabilities of the underlying hardware.
Coming back to point did you try

Yes GNOME 3.8 upgrade seems to be causing the issue

Hi since , this seems to be tumbleweed issue. Can you press the triangular icon at the bottom of post and ask the moderators to move this thread to tumblewwed?

OK, done that.

OK. When I get a minute, I’ll try that pre-load workaround (where can I get a previous glib version from though?). I’m about to go away for the weekend though, so it will be a while, sorry! :slight_smile:

Incidentally, the most reliable way I’ve found of causing the crash is to attempt to select the “Javadoc” view. It always crashes when you do this. Otherwise it seems to crash at arbitrary times, doing nothing in particular (though always linked to some click/type action, I think).

Thanks again for the help.

CLOSED and will be moved to Tumbleweed.

Moved from Applications and open again.

Can anyone confirm that this happens (or does not happen!) for them: running Eclipse Juno on openSUSE 12.3 32-bit (Tumbleweed), occasionally crashes with an undefined symbol, “g_simple_proxy_resolver_new”.

The quickest way I’ve found to provoke it is to open the Javadoc view and select it. That seems to fail every time, though it also fails elsewhere less predictably, such as while editing Java source in the editor.


I cannot confirm whether this issue is common or not, because I use neither Tumbleweed nor eclipse.

But that error message would indicate that your installed libgio-2_0-0 is too old for your (package “glib-networking”).
Please post the output of:

rpm -q libgio-2_0-0 glib-networking

If your libgio-2_0-0 is from Tumbleweed it should have version 2.36.1-2.3.
If not, please do

sudo zypper in -f libgio-2_0-0-2.36.1

to fix it.

Thanks very much for the help with this. The output is:

> rpm -q libgio-2_0-0 glib-networking

So trying to install the updated package, as you suggested, gets the following:

Forcing installation of 'libgio-2_0-0-2.36.1-2.3.i586' from repository 'openSUSE:Tumbleweed'.
Resolving package dependencies...

Problem: gio-branding-openSUSE-12.3-3.2.1.noarch requires libgio-2_0-0 = 2.34.3, but this requirement cannot be provided
 Solution 1: Following actions will be done:
  downgrade of gio-branding-openSUSE-12.3-3.2.1.noarch to gio-branding-openSUSE-12.3-2.1.noarch
  install gio-branding-openSUSE-12.3-2.1.noarch (with vendor change)
    openSUSE  -->  obs://
 Solution 2: do not install libgio-2_0-0-2.36.1-2.3.i586
 Solution 3: break gio-branding-openSUSE-12.3-3.2.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): 

I’m not sure what this is telling me.

I just tried doing a full “zypper dup”, which did pull in a few updates, but the above is unchanged, the “zypper in -f libgio-2_0-0-2.36.1” still fails and Eclipse is still having problems. Before this I only did one zypper dup to upgrade to 12.3 (is it sensible to do these at regular intervals, or just at major releases?)

That’s the reason why libgio-2_0-0-2.36 wasn’t installed by “zypper dup”. Tumbleweed seems to have gio-branding-openSUSE in a lower version than openSUSE 12.3 (you might want to report that on the factory mailinglist). But you need the newer libgio-2_0 to get glib-networking to work.
So select solution 1. This will switch gio-branding-openSUSE (and libgio-2_0) to the Tumbleweed version, and eclipse should work again…

Of course you should run “zypper dup” at regular intervals to get all Tumbleweed updates. That’s the whole point of Tumbleweed, isn’t it? :wink:
You could use “zypper dup --from openSUSE:Tumbleweed” to only upgrade packages that are in the Tumbleweed repo…

OK, I updated with option 1, and the rpms do now show the new version:

> rpm -q libgio-2_0-0 glib-networking

But when I try to run Eclipse Juno, it now SEGVs somewhere:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x7bc992d3, pid=1778, tid=3076474560
# JRE version: 7.0_17-b02
# Java VM: OpenJDK Client VM (23.7-b01 mixed mode linux-x86 )
# Problematic frame:
# C  []  soup_session_feature_detach+0x23

This seems to be it trying to start the “browser” parts of the Javadoc view, judging from the detailed JVM log:

Stack: [0xbf915000,0xbf965000],  sp=0xbf9619c0,  free space=306k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  []  soup_session_feature_detach+0x23
j  org.eclipse.swt.internal.webkit.WebKitGTK._soup_session_feature_detach(II)V+0
j  org.eclipse.swt.internal.webkit.WebKitGTK.soup_session_feature_detach(II)V+9
j  org.eclipse.swt.browser.WebKit.create(Lorg/eclipse/swt/widgets/Composite;I)V+892
j  org.eclipse.swt.browser.Browser.<init>(Lorg/eclipse/swt/widgets/Composite;I)V+81
j  org.eclipse.jdt.internal.ui.infoviews.JavadocView.internalCreatePartControl(Lorg/eclipse/swt/widgets/Composite;)V+7
j  org.eclipse.jdt.internal.ui.infoviews.AbstractInfoView.createPartControl(Lorg/eclipse/swt/widgets/Composite;)V+2
j  org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.createPartControl(Lorg/eclipse/ui/IWorkbenchPart;Lorg/eclipse/swt/widgets/Composite;)Z+2
j  org.eclipse.ui.internal.e4.compatibility.CompatibilityView.createPartControl(Lorg/eclipse/ui/IWorkbenchPart;Lorg/eclipse/swt/widgets/Composite;)Z+306
j  org.eclipse.ui.internal.e4.compatibility.CompatibilityPart.create()V+99

So progress of sorts, but still no Eclipse. :frowning: It may be OK if I steer clear of the Javadoc view, but I’ll need to use it for a while to be sure.

Looks like this is an Eclipse problem though! The -Dorg.eclipse.swt.browser.DefaultType=mozilla fix seems to work.

Thanks again for the help!

Sounds similar to this bug:
(should be fixed in Eclipse Juno 4.3)

You could try the workaround mentioned there (i.e. use Firefox as Javadoc viewer):

For a workaround add the following to the end of your eclipse.ini


Ah well. Somehow I overlooked your edit when I replied.
Glad it works now! :slight_smile:


Yes I have (had) the exact same problem. I have followed the suggestions regarding the downgrading the opensuse branding related rpm and was then able to install the correct libgio rpms. All works fine now. I did not experience the mozilla bug that you experienced subsequently.

Thanks for all the guidance.