eclipse juno crashs on OpenSuse 13.1

Running eclipse as “eclipse -vmargs -Dorg.eclipse.swt.browser.DefaultType=mozilla” seems to have solved the issue.

I wanted to suggest this right now.

I remember this was a problem with Juno a few months ago, but this was fixed then AFAIK…:\

I have no problems with Kepler. Everything seems to work fine. I just had to add


to the eclipse.ini

Java: java-1_7_0-openjdk

Well, exactly this seemed to fix his crashes as well, apparently… :wink:

I tried openSuse 13.1 with Gnome.
Same problem, Eclipse crashes with same error messages.

And have you tried to set your GTK2 theme to Raleigh?

Note that GNOME uses Gtk3, so changing the GNOME theme will likely not have any effect.
I’m not sure how you would set the Gtk2 theme in GNOME the best way nowadays…

Maybe try to edit ~/.gtkrc-2.0 by hand with a text editor. Change the line with “gtk-theme-name” to:


Or have a look here: gnome3 - Gtk2 Themes under Gentoo’s Gnome 3 - Unix & Linux Stack Exchange

After upgrade to 13.1 on an AMD 64 bit system, eclipse Indigo 3.7.2 crashed on a regular basis.
Changing from OpenJDK to Sun/Oracle made no difference.
Running from a command line displayed an error:

*** NSPlugin Viewer *** ERROR: /usr/lib/browser-plugins/ cannot open shared object file: No such file or directory

then also:

Problematic frame:

C [] soup_session_feature_detach+0x11

To handle the first problem I installed acroread with its browser plugins. I had to add another repository to my system.
Now the first problem is just giving a warning:

(npviewer.bin:4119): Gtk-WARNING **: Unable to locate theme engine in module_path: “oxygen-gtk”,

and also:

(acroread:4139): Gtk-WARNING **: Unable to locate theme engine in module_path: “oxygen-gtk”,

so to clean this up I installed gtk2-engine-oxygen-32bit (though it was just to clean things up).

Now to get to grips with the main problem:

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x00007fcd31dd2ee1, pid=4495, tid=140520774915840

JRE version: 6.0_26-b03

Java VM: Java HotSpot™ 64-Bit Server VM (20.1-b02 mixed mode linux-amd64 compressed oops)

Problematic frame:

C [] short+0x11

I did a bit of googling and found the eclipse forum item:

which had a solution that is mentioned earlier in this forum.

Find the eclipse.ini file in the eclipse home path and edit in:


This solved the problem for me but note that some also have to locate the XULRunnerPath and declare that in the file.
See comment 22 in the eclipse forum item.

I hope that this helps others.

seems to solve also my problem,
I am happy that I found a solution here!

makes it better, but not fixed.
Without this line it crashes every few seconds,
with this line it crashes every few minutes.
So, it makes it much better, but the problem is still existing.

The bug is in

Hi all,

I am using Aptana Studio 3 and I was getiing the same exact problem: C [] soup_session_feature_detach+0x11.

Likewise, I added the line -Dorg.eclipse.swt.browser.DefaultType=mozilla to the last line of the AptanaStudio3.ini and it worked like a charm, even with oxygen-gtk. I also removed icedtea-web as mentioned before but I am not sure if that helped solve my problem. Thanks a lot. Been looking for a solution for this for weeks.

I have updated Opensuse 13.1 to the latest libraries (Dec 17) but the problem still exists.


any news ? Is the problem already solved ?

Have the same problem! And it begins to made me mad.

It is no any possibility to work.

Decision that was offer “-Dorg.eclipse.swt.browser.DefaultType=mozilla” is work, but is not stable and doesn’t protects from crushes of java.

If somebody knows how to solve this problem please HELP! :slight_smile:

The problem of Eclipse crashing without warning, and without any error message, can be caused by the Google Talk (i.e., Google Hangouts) plugin. For me, Eclipse was crashing every time a popup window appeared. The problem disappeared once I removed the Google Talk plugin. See Eclipse Bug 334466 for further details.