Eclipse failing halfway Aptana Studio install?

I installed eclipse using the one click installer of webpin as it had a 3.4 version opposed to the 3.3 version that was in the OSS repository.

Then I tried to install a plugin (Aptana Sutdio) and it died at the last step (8. Click the Install All button. @ the above link).
So I thought it might be related to version 3.4 and uninstalled it, then wanted to install 3.3… but the oss respository has 3.4 now as well? So I just installed 3.4 from the OSS repository and tried again… with the same result, it fails at the last step.

Any log that contains information about what’s going wrong? I’m guessing it’s trying to install the plugin into a directory it can’t write to or something

Update on what does NOT work.
Tried copying /windows/C/Program Files(x86)/Eclipse/plugins contents over to /home/Pascal/.eclipse/org.eclipse.platform_3.4.0.1543616141/configuration/eclipse/plugins with no luck.
Perhaps the 64 bit jars differ from the 32 bit ones? Or it’s just the wrong location…

[EDIT]:
It was indeed the wrong location, placed the files in /usr/share/eclipse/plugins and it’s working. If you got the same problem and a window installation you might wanna try it this way.