Eclipse Europa on SuSE 11

This might not be specific to SuSE 11, might be specific only to this release of Eclipse which was installed from the SuSE 11 regular repository.

Googling, I only found many references to this error on Ubuntu/Kubuntu, but the fix recommended for those distros does not work on SuSE 11.

Problem
Installed Eclipse with Sun JDK 1.5.06.
When Eclipse is launched, the following error is displayed

Could not initialize the application’s security component. The most likely cause is problems with files in your application’s profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features.

Attempted Solution which doesn’t work
Debian solution has been to manually create the folder

$HOME/.mozilla/eclipse

I have also created the folder with the “Eclipse” foldername capitalized.

Any thoughts and recommendations appreciated.

TIA.

I use the last release - Ganymede - from tarball downloaded on Eclipse.org. It works fine. I have only strange artefacts in the bottom panel of KDE4.

I have installed Eclipse Ganymede and can report that at least initially the application runs (I haven’t actually tried to do anything in Eclipse yet)

For the newbie, here is some info regarding “installing” Eclipse from a tarball…

I installed and configured the preferred JDK before installing Eclipse, that involves not only downloading and installing (docs say Sun and maybe IBM version preferred over Open version), then configuring the JAVA_HOME and PATH environmentals.

Eclipse doesn’t “install” – You just extract the tarball to a chosen location and from there it will always run.

Initially I installed and ran as Root, but re-located the files to a location recommended by some docs I found on the Web in a subfolder of the /opts/ directory. From there, Eclipse should be accessible for any User.

The first time I ran Eclipse with a regular User account (from BASH window), the following error displayed

java.lang.OutOfMemoryError: requested 32756 bytes for ChunkPool::allocate.
Out of swap space?

The solution to this problem is to run the eclipse executable again with the -vmargs switch only once. After that, simply executing the eclipse executable is needed without the switch.

Ex.

/opt/Eclipse/eclipse -vmargs

Hope there aren’t additional errors to be found and this works for everyone else as well!

How are you running it? I click on the eclipse file and I get the “Open with…” dialog box. (It’s not just Eclipse, it’s every executable)
I’m running KDE x64.

Dunno. Are your running 32-bit or 64-bit Eclipse?

Hrm the Eclipse from the “standard” 11.0 oss/non-oss repository install worked out of the box for me.

However, I am using 1.6.0_06 as my Java, as 1.5 is bloody old :stuck_out_tongue:

I have a similar problem. I unzipped the tarball (tried this for Europa, Ganymede, Java, JEE and C++ packages) and double-clicked on the eclipse icon and nothing happened and this is as myself or as root, in my folder or in /opt with execute perms.

Even the command line does nothing. When I type in “eclipse” I just get “command not found”.

Is there a setting somewhere to do with running exes or am I missing something here?

I like Eclipse but if I can’t run the thing then it’s NetBeans for me.

Hi All,

Me too here, eclipse ganymede doesn’t run well on OpenSUSE 11.0.It freezes after creating a workspace . It was running well on SUSE 10.3. Am a developer i happen to have installed openSUSE 11.0 hoping to enjoy the new environment. I have been using 10.3. IS there a way out on how to run eclipse ganymede on OpenSUSE 11.0?

I’m running it on 11.1 without any problem. Installed from Java repo.

i had some problem with it but came to a solution. in my case i had not install jre and jdk wich I did.
For jre i have 1.6.0_16 i took it in the tarball form and executed:
chmod a+x jdk-6u16-linux-i586-rpm.bin (to extract the file)and
./jdk-6u16-linux-i586-rpm.bin (to execute).

the same thing i did for JDK after that i pinpointed to eclipse where the virtual machine is which in my case it was in:

                      /usr/java/jre1.6.0_16/bin/java

after that i went to the directory where extracted Ganymede and entered this command :
./eclipse -vm /usr/java/jre1.6.0_16/bin/java
after that i can open eclipse just by typing “./eclipse”
Note: to open eclipse i have to be into the extracted folder.

andywakeling;1881518 Wrote:
> I have a similar problem. I unzipped the tarball (tried this for Europa,
> Ganymede, Java, JEE and C++ packages) and double-clicked on the eclipse
> icon and nothing happened and this is as myself or as root, in my folder
> or in /opt with execute perms.
>
> Even the command line does nothing. When I type in “eclipse” I just get
> “command not found”.
>
> Is there a setting somewhere to do with running exes or am I missing
> something here?
>
> I like Eclipse but if I can’t run the thing then it’s NetBeans for me.
Hi All,

Me too here, eclipse ganymede doesn’t run well on OpenSUSE 11.0.It
freezes after creating a workspace . It was running well on SUSE 10.3.
Am a developer i happen to have installed openSUSE 11.0 hoping to enjoy
the new environment. I have been using 10.3. IS there a way out on how
to run eclipse ganymede on OpenSUSE 11.0?


smuwanga

smuwanga’s Profile: http://forums.opensuse.org/member.php?userid=8775
View this thread: http://forums.opensuse.org/showthread.php?t=387617

smuwanga;1929909 Wrote:
> Hi All,
>
> Me too here, eclipse ganymede doesn’t run well on OpenSUSE 11.0.It
> freezes after creating a workspace . It was running well on SUSE 10.3.
> Am a developer i happen to have installed openSUSE 11.0 hoping to enjoy
> the new environment. I have been using 10.3. IS there a way out on how
> to run eclipse ganymede on OpenSUSE 11.0?
I’m running it on 11.1 without any problem. Installed from Java repo.


http://yami.googlecode.com/
http://akoskm.blogspot.com/

ram88’s Profile: http://forums.opensuse.org/member.php?userid=1058
View this thread: http://forums.opensuse.org/showthread.php?t=387617