Eclipse callgraph + systemtap problems


I was interested in installing the Eclipse callgraph facility, which requires installing and configuring systemtap, but haven’t been successful, despite plenty of googling of various web-sites this weekend, so thought I’d better ask here too.

My pc is using Opensuse 12.1, the systemtap installed is v1.4.

The current issue I’m facing is the following, when I attempt to use the callgraph facility within Eclipse, it reports:

semantic error: process probes not available without kernel CONFIG_UTRACE while resolving probe point process("/home/gurce/workspace/hello/Debug/hello").end
Pass 2: analysis failed.  Try again with another '--vp 01' option.

Ok, I don’t know anything about systemtap, but I did take note of this missing ‘utrace’ facility.

There were suggestions online to install the “kernel-trace” flavour of kernel-packages. The description in yast of these packages mentions that they come with ‘utrace’ enabled:

kernel-trace - The Standard Kernel with Tracing Features
This kernel has different tracing features enabled (e.g. utrace, ftrace).

Ok then, these packages are now installed, I re-boot the os with this trace flavour, but I still get the same error above in eclipse when I try the callgraph facility (which uses systemtap).

Then I saw something on this site:
Chapter 4. User-Space Probing

It said I could confirm whether my current kernel supported utrace or not by typing in the following:

grep CONFIG_UTRACE /boot/config-`uname -r`

And indeed, my “/boot/config-3.1.10-1.9-trace” makes no mention of the “CONFIG_UTRACE” setting, implying that it isn’t enabled?

Can anyone fill me in what has happened here? I did notice there was some discussion in this thread of dropping support for utrace in future versions of Opensuse, is this what has happened? If so, perhaps the description of the “kernel-trace” packages is no longer accurate?

Re: [opensuse-kernel] Trace flavor still needed?

Will share this insight, just in-case others find themselves in the same situation. I asked the people in charge of the kernel-trace flavour about this, and learnt the following:

Hi Gurce -

We ultimately removed the utrace patches entirely from the openSUSE
kernel as they haven’t been accepted upstream.

  • -Jeff

Jeff Mahoney

Ah, so I guess this means that the Eclipse+callgraph facility will no longer work under OpenSuse 12.1 :frowning: