Eclipse 3.5 Tomcat 6.x

Hello

I’m running OpenSuse 11.2.
I’m working with a simply unpacked Eclipse 3.5 version
and installed tomcat6 via repo manager.

When I try to set up a new tomcat6.x server and give’em the directory
/usr/share/tomcat6
which includes all files nicely as symbolic links

drwxr-xr-x 2 root root 4096 2010-06-18 01:59 bin
lrwxrwxrwx 1 root root 12 2010-06-18 01:59 conf → /etc/tomcat6
lrwxrwxrwx 1 root root 15 2010-06-18 01:59 lib → …/java/tomcat6
lrwxrwxrwx 1 root root 16 2010-06-18 01:59 logs → /var/log/tomcat6
lrwxrwxrwx 1 root root 23 2010-06-18 01:59 temp → /var/cache/tomcat6/temp
lrwxrwxrwx 1 root root 20 2010-06-18 01:59 webapps → /srv/tomcat6/webapps
lrwxrwxrwx 1 root root 18 2010-06-18 01:59 work → /var/cache/tomcat6

still when I give eclipse that directory it just says:
The Tomcat installation directory is not valid. It is missing expected file or folder lib/servlet-api.jar (alternate name [servletapi6].jar).

Funny though it seems to pick a different file once a while sometimes it’s the bin files sometimes the lib files, I suppose it’s a matter of it’s mood.

anyone any Ideas?

thanks
Granit

Well well seems I fixed issue one but it only lead to issue two…
It seemed that the servlet-api had a ridiculous name so I made another symlink.

now the issue is even nicer:
When attempting to start the server via eclipse
it views the nice and clear Error msg:

“Server Tomcatv6.0 at localhost failed to start”

of course that is obviously the case but it doesn’t seem to want to tell me
why it doesn’t start.

I find this disturbing and annoying as this is such a simple 4 click solution on any windows system how is it possibly this difficult?

regards
Granit

Probably because you don’t have permissions in the tomcat directory. Generally tomcat is started at boot time as a service. If you want to deploy in the war directory, then make it owned by you.

I ran eclipse as root to avoid such issues, once it runs I’d make sure the owner is correct.

But you’re idea of tomcat already running certainly helped.

Stopped tomcat and ran it with eclipse now getting:

“Could not find the main class: org.apache.catalina.startup.Bootstrap. Program will exit.”

Bootstrap.jar is in
/usr/share/tomcat6/bin
and should be recognized.

All problems solved, found the solution in a post on
Server Tomcat v6.0 Server at localhost failed to start - Stack Overflow
which was saying:


I found the solution here: tomcat6 + eclipse not working - openSUSE Forums

  1. In Eclipse, Open the “Server” tab.
  2. Double click on the “Tomcat6” entry to see the configuration.
  3. Then click on the “Open launch configuration” link in the “General information” block.
  4. In the dialog, select the “Classpath” tab.
  5. Click the “Add external jar” button.
  6. Select the file “/usr/share/tomcat6/bin/tomcat-juli.jar”
  7. Close the dialog.
  8. Start tomcat 6 from Eclipse.

Hopefully posting it here will help some poor soul.


Well as this seems to be in this forum maybe the redundancy of this thread should be taken into consideration.

Thanks anyway
Granit

On Fri, 18 Jun 2010 14:06:02 GMT, DrGranit
<DrGranit@no-mx.forums.opensuse.org> wrote:

>
>I ran eclipse as root to avoid such issues, once it runs I’d make sure
>the owner is correct.

Unfortunately for you, that is one of the surest ways to create them. Due
to well enforced ownership rules in *nix, it is proper technique to run
things only as the normal user/owner. It is much the opposite in Redmond
OSs. In both OS styles, initialization runs create lots of new files;
the access rights to these configuration files often controls whether or
not the application runs correctly.