Easycap DC60 driver problem

Hello all.

I’m making an attempt to install drivers for my easycap dc60 USB video capture device. Someone was good enough to make a driver project on sourceforge. Problem is I cannot get it compiled.

make[1]: Entering directory `/home/jan-bart/Download/easycap_dc60.0.4/src'
make -C /usr/src/linux-headers-`uname -r` M=/home/jan-bart/Download/easycap_dc60.0.4/src modules
make: Entering an unknown directory
make: *** /usr/src/linux-headers- No such file or directory.  Stop.
make: Leaving an unknown directory
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/jan-bart/Download/easycap_dc60.0.4/src'
make: *** [build] Error 2

I have kernel-source, kernel-syms and kernel-headers installed and that always worked fine.

I’m currently using the desktop kernel in 11.2

Dexter:/home/jan-bart/Download/easycap_dc60.0.4 # rpm --query --all '*kernel*'

Any help would be appreciated.


The Makefile has been tested for Debian and Ubuntu, but I am beginning to realize that it will need to be modified to cope with other distributions. I’d be interested to hear what works on OpenSUSE. As a first step I’d suggest editing src/Makefile so that the line which sets KERNELDIR becomes something like

KERNELDIR ?= /full/path/to/the/kernel/headers/on/OpenSUSE

That may not be the end of the problems however. On Debian and Ubuntu successful installation of the module is most easily done by running the installation script ./install.sh, and I would recommend trying this. If the installation script fails it will at least generate some diagnostics which might be useful.


After replacing the kernel dir it complained it did not have a correct configuration. I ran ‘make oldconfig’ and ‘make prepare’. This seemed to satisfy at least that step. Next problem is the following:

jan-bart@Dexter:~/Download/easycap_dc60.0.4> sudo ./install.sh
root's password:
depmod OK
clean OK
compile OK
ERROR:  step failed:  make
/bin/sh: scripts/mod/modpost: No such file or directory
make[3]: *** [__modpost] Error 127
make[2]: *** [modules] Error 2
make[1]: *** [all] Error 2
make: *** [build] Error 2

Any suggestions here? I’m sorry to be asking this but compiling things is not my strong point :slight_smile:

I’m not the best person to advise you on this because I’m not running OpenSUSE myself. Something seems wrong with the kernel headers, but I don’t know what the problem is. I went to Google and searched for

scripts mod modpost not found

and got a couple of hits that might be interesting:

incentivespro.com :: View topic - modpost missing

Cool Solutions: Compiling Kernel Drivers for SUSE 10 By Example

but I’m not sure. I’m sorry I can’t be more helpful.


I installed openSUSE 11.2 on one of my machines and
investigated. The procedure for building modules on openSUSE is indeed somewhat different from that on Debian/Ubuntu. Therefore in the latest version 0.5 of the easycap driver I have included a Makefile_openSUSE and have added some notes for openSUSE users to the README file. I hope this will make things a little easier. Today I have successfully built version 0.5 of the driver on openSUSE 11.2 against the 64-bit version of the kernel

By the way, I like openSUSE. It is the only distribution I know about which provides hardware acceleration with my Radeon graphics card.


Will give it a try and report back here…

Just for my curiosity, is there an easy (read GUI) way of recording the video? I don’t like using the mplayer way and not be able to see anything whiles it’s recording…

Thanks for your work so far!