EA games mostwanted not working

help any please help me

i installed directx 9 as well as EA mostwanted game using WINE

but when i try to start it it gives a black screened windows and just closes after a few seconds ( about 5)

can any help me to play that game correctly

Take a look to wine’s appdb. Maybe they already have a solution. Are you installed DirectX/Most Wanted with wine-doors on directly with wine?

yes i installed directly with wine

by just clicking open with wine

any way fixed it by turning off the pixel shader

but the game runs very slow on my system

not able to play

it used to play like charm in windows with ati drivers and directx 10

but in linux i cant help me

i did not configure sax2 for 3d acceleration
can you guide me for that

Hello all,I just wanted to introduce myself,I am new here and I hope to have a very nice time on this forum.

i did not configure sax2 for 3d acceleration
can you guide me for that

Hi momofooze. You need to supply more details concerning your graphics system. Then someone may be able to help you get 3D acceleration working.

One way to provide this info is to type the following command into a console and post the output here:

/usr/sbin/hwinfo --gfxcard

This will tell us more about your hardware and current driver being used.

thanks for your reply

this is the output

junodor@linux-ju1d:~> /usr/sbin/hwinfo --gfxcard
20: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_1002_5a61
Unique ID: ul7N.n3FKoMfWx+7
Parent ID: vSkL.dQFUNbiC_g9
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: “ATI Radeon XPRESS 200 5A61 (PCIE)”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x5a61 “Radeon XPRESS 200 5A61 (PCIE)”
SubVendor: pci 0x8086 “Intel Corporation”
SubDevice: pci 0xd601
Driver: “fglrx_pci”
Driver Modules: “fglrx”
Memory Range: 0x40000000-0x4fffffff (rw,prefetchable)
I/O Ports: 0x2000-0x2fff (rw)
Memory Range: 0x60100000-0x6010ffff (rw,non-prefetchable)
Memory Range: 0x50000000-0x5001ffff (ro,prefetchable,disabled)
IRQ: 17 (154142 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00005A61sv00008086sd0000D601bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeon
Driver Info #1:
XFree86 v4 Server Module: fglrx
3D Support: yes
Extensions: dri
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #20

i any how managed to run the game

but the audio gets stuck in middle of the game repeating a single sound and after a few seconds the windows closes

no problem with 3d

The output shows that you’re already using fglrx driver and that 3D support is enabled. You may get better support for your wine (sound problem) from http://wiki.winehq.org/

yeah i have no problem with 3d now i solved it by updating my drivers to ati-driver-9.3

but the problem now is the sound gets stuck in the middle and the game stops by closing its own default wine window

i still have the same sound problem

can any one help me out

Try posting here:

FrontPage - The Official Wine Wiki

I think you’ll have a better chance of getting the help you need from a wine-specific forum.

thank you very much i will try it out

in tried every thing in wine’s forum

but could’nt get any better solution

is there any thing to do with ALSA/OSS

or any thing with pulseaudio

i heard about Esound too

any ideas please!

I’m out of my depth as far as sound issues go. PulseAudio is only relevant if using Gnome desktop AFAIK. If you have it installed and think its the cause of your problem then you can remove it. Refer to this thread:

How to uninstall Pulseaudio and install esound - openSUSE Forums

You may also wishto try using Cedega (Transgaming’s proprietary version of wine) which may offer better results and support.

The linuX-gamers.net - ENJOY Linux Games site has a forum which may also be of value to you.

thanks for all the effort you have made

i will try those

if you would like to play ea games on linux this can be done by visiting the codeweaves website and you can purchase thier game emulator it allows you to play all of the popular windows games on suse linux
i play tom clancys rainbow six series and have no problems www.codeweaver.com