DWA-131 drivers installation

How do I install the drivers for the D-Link nano wireless adapter. I’ve downloaded the* rtl8192eu-linux-driver* and usually all I would need to do in a Debian based distro is make then make install. But this is not working. It is returning an error that says command not found.

Then install it. You also need to install kernel-default-devel package which contains files necessary to build external modules as well as compile/build tools. All of this may be installed with “zypper in -t pattern kernel_devel”.

Please all things that can be shown instead of told about are better to be shown. Thus copy/paste your prompt, command, what it outputs and the next prompt (to show it is complete) between CODE tags in a post. You get the CODE tags by clicking on the # button in the tool bar of the post editor.

An example:

henk@boven:~> make
If 'make' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf make
henk@boven:~> 

This is off course to be done the next time you do something similar, because avidjaar understood already what you experienced.

Maybe your Wifi is supported by Tumbleweed kernel?
Please show:

lsusb

I think, its a USB Wifi Adapter.

Otherwise:

/sbin/lspci -nnk | grep -iA3 net

Hello,
I’m trying to make the same compilation in RPI3 but with this error during make:

testt38:~/rtl8192eu-linux-driver # make
make ARCH=aarch64 CROSS_COMPILE= -C /lib/modules/4.4.39-5-default/build M=/root/rtl8192eu-linux-driver  modules
make[1]: Entering directory '/usr/src/linux-4.4.39-5-obj/arm64/default'
/usr/src/linux-4.4.39-5/Makefile:638: arch/aarch64/Makefile: No such file or directory
make[3]: *** No rule to make target 'arch/aarch64/Makefile'.  Stop.
make[2]: *** [Makefile:150: sub-make] Error 2
make[1]: *** [Makefile:24: __sub-make] Error 2
make[1]: Leaving directory '/usr/src/linux-4.4.39-5-obj/arm64/default'
make: *** [Makefile:1335: modules] Error 2

It seems that my architecture is not supported for this driver compilation, anybody could help me?

This is lsusb exit:

Bus 001 Device 006: ID 2001:3319 D-Link Corp.
Bus 001 Device 005: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 001 Device 004: ID 03f0:034a Hewlett-Packard Elite Keyboard
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

If I check hwinfo --wlan nothing is showed, but with a simple hwinfo command a part of the info showed is:

usb device: name = 1-1.5:1.0
    path = /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0
    modalias = "usb:v2001p3319d0200dc00dsc00dp00icFFiscFFipFFin00"
    bInterfaceNumber = 0
    bInterfaceClass = 255
    bInterfaceSubClass = 255
    bInterfaceProtocol = 255
    if: 1-1.5:1.0 @ /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5
    bDeviceClass = 0
    bDeviceSubClass = 0
    bDeviceProtocol = 0
    idVendor = 0x2001
    idProduct = 0x3319
    manufacturer = "Realtek"
    product = "Wireless N Nano USB Adapter"
    serial = "00e04c000001"
    bcdDevice = 0200
    speed = "480"

and

P: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5
  N: bus/usb/001/006
  E: BUSNUM=001
  E: DEVNAME=/dev/bus/usb/001/006
  E: DEVNUM=006
  E: DEVPATH=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5
  E: DEVTYPE=usb_device
  E: DRIVER=usb
  E: ID_BUS=usb
  E: ID_MODEL=Wireless_N_Nano_USB_Adapter
  E: ID_MODEL_ENC=Wireless\x20N\x20Nano\x20USB\x20Adapter
  E: ID_MODEL_ID=3319
  E: ID_REVISION=0200
  E: ID_SERIAL=Realtek_Wireless_N_Nano_USB_Adapter_00e04c000001
  E: ID_SERIAL_SHORT=00e04c000001
  E: ID_USB_INTERFACES=:ffffff:
  E: ID_VENDOR=Realtek
  E: ID_VENDOR_ENC=Realtek
  E: ID_VENDOR_FROM_DATABASE=D-Link Corp.
  E: ID_VENDOR_ID=2001
  E: MAJOR=189
  E: MINOR=5
  E: PRODUCT=2001/3319/200
  E: SUBSYSTEM=usb
  E: TYPE=0/0/0
  E: USEC_INITIALIZED=12534584
  
  P: /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0
  E: DEVPATH=/devices/platform/soc/3f980000.usb/usb1/1-1/1-1.5/1-1.5:1.0
  E: DEVTYPE=usb_interface
  E: ID_VENDOR_FROM_DATABASE=D-Link Corp.
  E: INTERFACE=255/255/255
  E: MODALIAS=usb:v2001p3319d0200dc00dsc00dp00icFFiscFFipFFin00
  E: PRODUCT=2001/3319/200
  E: SUBSYSTEM=usb
  E: TYPE=0/0/0
  E: USEC_INITIALIZED=12549477

which means that my usb wifi dongle is recognized by the system although not associated to any driver thus, I assume the system don’t know how to use it.

I’ve also tried to download rtl8xxxu-4.7.0-1.7.src.rpm package from https://software.opensuse.org/package/rtl8xxxu, I’ve already installed this source package and created an .rpm installable package with rpmbuild. THen I’ve installed it but my dongle is still with no driver associated.

What can I do?
Thanks a lot!

You could try compiling directly on the R.Pi itself

http://gibbalog.blogspot.co.nz/2015/11/compiling-8192eu-driver-for-raspberry-pi.html

Maybe there is an easier way (even without any compilation) depending on the presence of “rtl8xxxu” in your target system/kernel.

With a x86 4.4.39 default kernel, the module should be there, but I have no idea if the module is present in the respective ARM kernel for a RPI.


/sbin/modinfo rtl8xxxu

says?

AK

//Edit:

Nope, unfortunately not in this case, after loading rtl8xxxu there is now “new_id” section in /sys/bus/usb/drivers/rtl8xxxu, so the little trick I had in mind won’t work here.

AK

Maybe we had the same trick in mind but as you could test, I have not been able to apply it because there isn’t “new_id” section in /sys/bus/usb/drivers/rtl8xxxu.
Any idea to be able to use my wifi dongle?!

dpatino82 schrieb:

> Any idea to be able to use my wifi dongle?!
>
>

Not without recompilation.

You could take the sources of rtl8xxxu, find the correct section for USB-IDs of
supported devices, patch that file (adding your device ID) and recompile the driver.

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

OK, I’ve downloaded rtl8xxxu-4.7.0-1.7.src.rpm source package from https://software.opensuse.org/package/rtl8xxxu, I’ve searched where to add the USB-ID and in my view that is in rtl8xxxu_core.c file located in /usr/src/packages/SOURCES/rtl8xxxu-4.7.0.tar.bz2 so I’ve extracted it and modified this file adding my device ID (3319 because lsusb command show: Bus 001 Device 006: ID 2001:3319 D-Link Corp.) with:

{USB_DEVICE_AND_INTERFACE_INFO(USB_VENDOR_ID_REALTEK, 0x3319, 0xff, 0xff, 0xff),
    .driver_info = (unsigned long)&rtl8192eu_fops},

Then, compress it again and create .rpm package using:

rpmbuild -bb /usr/src/packages/SPECS/rtl8xxxu.spec

However, once the patched .rpm package is created and installed with zypper, I’ve rebooted the system but wifi dongle is still not working properly I mean, not associated with the driver and obviously rtl8xxxu module is not loaded on startup. Where is my error? Have I to patch another file?
It is interesting to note that the original package created without patch, rebuilds initrd after install it but since I’ve patched it doesn’t.

Any suggestion?
Thanks a lot!

Am Wed, 11 Jan 2017 11:16:02 GMT
schrieb dpatino82 <dpatino82@no-mx.forums.microfocus.com>:

> Where is my error?

At least one error is right here:

> command show: Bus 001 Device 006: ID 2001:3319 D-Link Corp.) with:
>
> Code:
> --------------------
> {USB_DEVICE_AND_INTERFACE_INFO(USB_VENDOR_ID_REALTEK, 0x3319, 0xff, 0xff,
> 0xff), .driver_info = (unsigned long)&rtl8192eu_fops},
> --------------------
>
>

That would not be 2001:3319 but 0bda:3319 as “USB_VENDOR_ID_REALTEK” resolves
to 0x0bda, so use the correct (numerical) Vendor ID.

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

OMG many many thanks!!!
You’re absolutely right, at first I didn’t undestand your tip, although when I’ve checked the “modinfo rtl8xxxu” information, I’ve realized my mistake because there wasn’t any line with 2001 3319 IDs. USB_VENDOR_ID_REALTEK parameter is defined at the top of the related file like:

#define USB_VENDOR_ID_REALTEK        0x0bda

but it isn’t the vendor ID of mi USB which really is 0x2001 (D-Link), so the patched lines would be:

{USB_DEVICE_AND_INTERFACE_INFO(0x2001, 0x3319, 0xff, 0xff,
> 0xff), .driver_info = (unsigned long)&rtl8192eu_fops},

So now my dongle wifi is working properly, thank you very much Akoellh for your interest and your help.

Am Wed, 11 Jan 2017 15:26:01 GMT
schrieb dpatino82 <dpatino82@no-mx.forums.microfocus.com>:

> Code:
> --------------------
> {USB_DEVICE_AND_INTERFACE_INFO(0x2001, 0x3319, 0xff, 0xff,
> > 0xff), .driver_info = (unsigned long)&rtl8192eu_fops},
> --------------------
>
>
> So now my dongle wifi is working properly, thank you very much
> -Akoellh- for your interest and your help.
>
>

Well, as we say in germany

“Kaum macht man es richtig, schon funktioniert es”

(The moment you are doing it right, it starts to work)

But, the story is not over yet, or to be precise it should not be over yet.

Do you care about helping the community and maybe get a little “fame” in return?

The best way to do that would be to inform the maintainer(s) of that driver so
they will ad the respective ID to their driver so the device will work out of
the box in the near future.

You can just add a link to this thread to your email and for confirmation and
it is very likely things will get rolling very soon.

Simply run

/sbin/modinfo rtl8xxxu | grep author

to get the address and send a mail to the maintainer.

In my experience, maintainers are quite happy to get such confirmations and if
there will be a patch (and you do agree) you might even be mentioned as a
contributor to the linux kernel.

In this special case, I am pretty sure the maintainer will be glad to get your
report, just search for the maintainer’s name in “rtl8xxxu_core.c” and read the
line starting with “please report”.

If you want, you can report success here (or CC me in your email to the
maintainer) and I will add the respective ID to my OBS packages (I am pretty
sure you downloaded my packages for your test) in order to get this fix/change
out ASAP so everybody will benefit from this thread here,

If you want to add me (CC) to the email conversation with the maintainer of
rtl8xxxu, just run

rpm -q --changelog rtl8xxxu-kmp-default

or have a look into the spec/changes file of the src.rpm to get my address.

I will not post any email addresses here as I am getting enough SPAM already.

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

Update:

The maintainer of this driver has been contacted by dpatino82 and the
device ID 2001:3319 will be added in the near future.

In the meantime I have updated my OBS packages (rtl8xxxu) at

http://download.opensuse.org/repositories/home:/Akoellh:/Kernelmodules/

to version 4.9.992 adding 2001:3319.

Additionally, this driver supports 4 device IDs that (most likely) will also be
included in the near future, however as “UNTESTED”.

These USB-IDs are

2357:0107

2357:0108

2019:ab33

0bda:818c

If you have one of these devices, you can test my OBS packages if your device
is now working with the rtl8xxxu driver.

If that test is successful, please report here or contact the developer Jes
Sorensen (Jes.Sorensen AT redhat.com) so they can be moved to the section of
TESTED drivers.

Even more important, if the test is not successful, please also report here as
that ID then should be removed from the driver.

AK

Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

Final Update:

Changes are upstream now, will be included in Linux 4.11.

AK


Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)