DVDs won't play until I mount them?

I just tried playing my Tim Minchin DVD through Totem in 11.2 (the wife doesn’t like him, so I might as well do it on the computer :slight_smile: ) and got errors about not having permissions. Running it from the terminal I got errors about encryption, so I installed libdvdcss from Packman’s script*. After that I still got the same error in the UI, but got the following on the console:

libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Invalid IFO for VMGM (VIDEO_TS.IFO).
libdvdread: Using libdvdcss version 1.2.10 for DVD access
libdvdread: Invalid IFO for VMGM (VIDEO_TS.IFO).
** Message: no file info
** Message: Error: Could not read title information for DVD.
resindvdsrc.c(364): rsn_dvdsrc_start (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/RsnDvdBin:source/resinDvdSrc:dvdsrc:
system error: Input/output error

(the only change from before was that it now used libdvdcss - the “could not read title” was the same). I hunted around the Internet and could only find some bug reports on Ubuntu. A thought suddenly struck me that my Creative Zen player wouldn’t be picked up by Banshee until I unmounted it (under Fedora at work rather than on openSUSE at home, IIRC), so I tried unmounting the DVD and playing it again and wooosh, I’m off!

So, is that expected? When Gnome pops up a dialog and says "I just found a DVD? Do you want me to play it through Totem then should it really fail until I unmount it? Is this a common issue that needs reporting, or do I just have something odd in my config somewhere?

Also, I know there are legal issues over libdvdcss (repeat footnote :wink: ) but couldn’t there be an easier way to get it set up, similar to the way Flash is pulled in? It wasn’t too bad as a techy, but it could be easier and I’m sure Fedora always had a simpler setup.


  • Note to movie studios: I bought the d’mned DVD/music/other and paid for it. You sold it to me for a one-time fee with no extra contract involved. Stop pissing me around with Digital Restrictions Management and other broken implementations of legitimate consumer punishment.

Rant over.

[Edited to replace “da_mn_ed” with something other than asterisks, even though pissing wasn’t filtered!]

Okaaaayyyy…I just removed a couple of packages from Packman’s repo that I’d installed to try to get it working but which hadn’t seemed to have an effect (libdvdplay and libdvdread3 because I already had) and then tested it again and now it works even when mounted. Huh? Maybe one of the updates for a seemingly unrelated package fixed it, or maybe it was a one-off, or maybe it was the error “DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending” (although Nautilus can still browse it) but now it works without having to manually unmount. Weird…