DVD-R works on Windows but not on Opensuse 11 / KDE 4

I’ve got a DVD-R that’s not recognized by Opensuse 11 / KDE 4. I’ve just tried it on a windows machine and it worked. Can somebody help me??? :frowning:

I think you also have the very common problem due to permission. Just look for the permissions of your devices. Also look for older posts in this forum. There are many posts with this issue.

What permissions should I check?

I’m not in front of my laptop right now, I’ll check them as soon as I get home.

I had the same problem but not with DVD+R. How does permissions come into this? I have a lot of DVD-R blanks.

Check the permission of /dev/sr0 (with ls -l). Add yourself (the user as which you login) in the disk and the other cdrom (maybe also dvdrom, not sure bcoz now I’m in Fedora) group by YaST.

Problem is solved read here

I’ll try that in a few hours. Thanks!!!

If the first suggestion does not work I’ll try this one.

Thanks!!!

Guys, I tried both options with no results…:frowning:

What’s the output of your

ls -l /dev/sr0

I’m at the office right now, in a few hours I’ll post the output.:shame:

Thanks for the quick reply.:slight_smile:

This is the output:

brw-rw----+ 1 root disk 11, 0 2009-01-07 22:46 /dev/sr0

5u4r3z wrote:
> This is the output:
>
> brw-rw----+ 1 root disk 11, 0 2009-01-07 22:46 /dev/sr0

Try the following command: ‘sudo chmod 666 /dev/sr0’. That will allow
anyone to r/w the device.

Larry

But it seems that it has permission ok. Have you added yourself to the group “disk” ??

Yes, I added myself to that group.

:\ This problem is not solved yet…

More ideas?

I’ll try:P

Go to Yast > Hardware > hardware info
it will take a minute or two to detect every thing

what does the detection show under “cdrom”?

I say that because in my x86-64 install my dvdrw is /dev/hda & cdrom is /dev/hdb which is as it should be in my mind as they are connected to the hd secondary controller (they are not sata drives). This, to me, is different than 11.0 where they were /dev/sr0 & /dev/sr1.

Back to your question:
once you know how the system shows the device(s), in most applications there will be a context menu where you can change the settings for the devices, e.g.,
K3b is Settings > Devices
Kaffeine is one-of the-context-menus > Xine-Engine Parameters > Devices
etc.

And if there is no way to change them if they are different. use a sym-link.
Example only:
in a terminal as root
“ln -s /dev/hda /dev/sr0”
“ln -s /dev/hdb /dev/sr1”
Yours will be whatever your system & application shows – if they are different & probably will be;)

If that doesn’t help get back & someone will surely try to assist:)

It says “DVDRAM GSA-T50L” and /dev/sr0

Hi.

I had the same thing with opensuse 11.1 - kde 3

(its always opensuse that has issues with opening drives - i never get this with debian/ubuntu/arch…)

Here is how i fixed it.

I added myself to following groups

groups
users disk wheel uucp dialout audio floppy cdrom video

I was still unable to use drive till I re-logged in (i rebooted)

If you still cannot use it try launching k3b using kdesu (this should access it as root) - then you will know it is a permissions issue.

Thanks. I’ll try that. I’ll post the results as soon as I can.