DVD R/RW Drive not working!!

How do i install my drive so that i can burn some dvds? I can burn on windows so i know it still works, but i cant get Linux to recognize it. Please help!!!

I dont know how to get the specs for the DVD drive through terminal, so i cant post what i have.

What kind of drive to you have? Is it external (usb connected), or internal? Most just work out of the box. Have you tried inserting a data cd/dvd and viewing with dolphin,konqueror, or nautilus?

With dvd drive connected, what do the following commands return?

/usr/sbin/hwinfo --cdrom

If usb,


After doing first command:

yeehaw@linux-faaw:~> /usr/sbin/hwinfo --cdrom
18: SCSI 300.0: 10602 CD-ROM (DVD)
[Created at block.249]
Unique ID: KD9E.QnnbMFcjhj4
Parent ID: 3p2J.6GedvM4mjr2
SysFS ID: /class/block/sr0
SysFS BusID: 3:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:1f.1/host3/target3:0:0/3:0:0:0
Hardware Class: cdrom
Model: “Optiarc DVD RW AD-7530B”
Vendor: “Optiarc”
Device: “DVD RW AD-7530B”
Revision: “NH02”
Driver: “ata_piix”, “sr”
Driver Modules: “ata_piix”
Device File: /dev/sr0 (/dev/sg1)
Device Files: /dev/sr0, /dev/block/11:0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.1-scsi-0:0:0:0, /dev/disk/by-label/CDROM, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
Device Number: block 11:0 (char 21:1)
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (IDE interface)
Drive Speed: 24
Volume ID: “CDROM”
Publisher: “SUSE LINUX Products GmbH”
Preparer: “KIWI - http://kiwi.berlios.de
Creation date: “2010061611233700”
El Torito info: platform 0, bootable
Boot Catalog: at sector 0x0032
Id String: “SUSE LINUX Products Gmb”
Media: none starting at sector 0x0033
Load: 2048 bytes
yeehaw@linux-faaw:~> lsscsi
[0:0:0:0] disk ATA WDC WD3200BEVT-1 11.0 /dev/sda
[3:0:0:0] cd/dvd Optiarc DVD RW AD-7530B NH02 /dev/sr0

Seems to be working fine. What burning programs have you tried? k3b?

What’s the exact problem? I believe your user must be member of the cdrom and disk groups (or maybe just disk) in order to be able to burn.

No, nobody should be a member of group disk, except perhaps backup programs. Group disk has access to the raw disk devices which is dangerous and insecure for users to have. That advice to put someone in group disk was back in one release (11.1?) when people found that (I think) udev put cdroms in group disk, and this workaround was devised, and the bad advice stuck even after the udev rules were fixed.

OK, sorry for the bad advice. It’s just that I was unable to burn a CD-RW yesterday (either with k3b or brasero), and finally managed to do it after adding my user to those two groups (cdrom and disk). So I guess there’s a better solution, but I don’t know what it is. I’ll open another thread for my problem.

deano_ferrari, I have been looking for a command that would give all of the drive device names for each optical drive in your system and the following command seems to do it for internal drives.

/usr/sbin/hwinfo --cdrom

Thanks so much for posting that command.

Thank You,

Thanks so much for posting that command.

Glad it was helpful.

man hwinfo for more options.

FWIW, Ubuntu (and probably other distro) users often use a similar lshw utility. It is also available as an openSUSE package.

K3B is what i am using. It wont even read my CD or DVD’s. this is how i know i have a problem. Now i am really no stranger to computers, i am just a stranger to Linux. I would figure that there was a firmware update for the device, but in searching for it, i can not find it. I just installed this OS two days ago, including today. This is a learning time for me, (the first two weeks that is) LOL.

Can you tell us more about what kind of CD/DVDs you’re referring to? Data, video, music? Only data CDs or DVDs will actually mount (with a file system) as such, but other types should still be able to be copied ok.

A normal file manager like konqueror, dolphin, or nautilus can be used to navigate a data CD/DVD.

A nice little k3b intro:

Burn CDs, DVDs and ISOs with K3b | Linux.com

i tried to make a copy of the SUSE live disk for my brother in law, it would not even read the data disk. I did a search for the drive today and had no luck. Its as if it says its there, but its really not. This is why i am stumped. I have seen this before on windows, but i just uninstalled the hardware and reinstalled it after restart. I have a feeling that linux does not work that way LOL

What’s the history of this drive? Is your machine dual boot, and does it work under the other OS? Have you tried booting any live Linux CD using the DVD drive?

It’s not impossible to encounter faulty drives, DVD/CD drives fail all the time. What worked yesterday might fail today. And sometimes it might come good for a while and fail again. In addition, it also happens that combo drives will read DVDs fine, but fail on CDs, or the other way around. Different lasers are used.

So it might be a hardware problem. But open up your computer and reseat all the cables for this drive just to make sure. And clean out any dust while you are at it.

I saw this as well with the Beta (RC1) 11.3 install , even tried live CD 11.3 RC1 and for some reason KDE 4 is not mounting the drives , the drive is there as far as HAL is concerned , maybe the build I DLed is screwy .
In “My Computer” Konqueror does not see the drive in fact no disc at all HD , CD , DVD , USB/HD/Thumb Drive etc… I had to reinstall 11.2 , needed a clean install anyways been pilling stuff on since KDE4.0 , anyways he got the 11.3 RC1 from me , so the 11.3 RC1 I DLed must have a fault in it for it to do the same thing on 2 different systems .
Sorry for the confusion , but like I said it is a Beta RC1 , I have 11.2 Final you can install and be in business , you really need to be a seasoned Linux user to mess with Betas and RCs and not expect a perfect environment out of them .

Your Computer is Okay , just the OS is Beta , don’t go messing with hardware it is all still good , just let me burn you a disc of openSUSE 11.2 final .
Tried to talk you out of the 11.3 RC1 stuff .
13 DAYS TILL 11.3 Final .

Just saw 11.3 RC2 , and noticed the bug for Hal in RC1 .
So it was a known bug with 11.3 RC1 .

Might try : First, let zypper download all required packages:

zypper dup -d

After all the required packages have been downloaded, we can do a system upgrade safely: 

zypper dup

THis thread was solved. Thank you to all that have responded