DVD problem since upgrading


I’m, having problems using my DVD. I think it started after the last automatic upgrade of openSUSE11 a few days ago. before that everything was cool.

I tried to follow some of the things said in this forum about this, but it looks as if it got worse.

Right now I get the following error message: Cannot mount volume.
A second error message pops up right away telling :
Unable to mount location"

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

help me . :’( I’m losing it… >:)

this kinda caught my eye since there have been some issues with upgrading and not having devices work. are you using 11.1 or 11.0? is it possible to restore to before the last set of updates(if for no other reason that finding the update packages)? where is your dvd assigned to mount? i think with a little digging this can be sorted out as upgrading tends to lead to some configuration issues.

I have SUSE11.1.
I do not know what package was install since upgrading is done on
my system every day. I do not remember exactly when problem started to show.

about mounting: I followed some advice in this forum and logged in as root via su.
next I entered this line
mount -v -t iso9660 -r /dev/sr0 /mnt

and got
/dev/sr0 on /mnt type iso9660 (ro)

that it.
can we progress from here?

there may be an issue with forcing the mount at sr0 especially if the drive is an external(?) i don’t see any issues with the output of the mnt command. you may want to check yast-> hardware-> hardware information for the /dev folder the system is looking for for the particular drive as it may not be sr0 and that particular drive is using a different dev folder. as in the case of my external dvd(uses sr1) the one digit difference can wreak a bit of havoc on behavior

just to simplify things if you could post the output of hwinfo here it might be easier than relaying pieces

OK. this is the output of hwinfo --cdrom

24: SCSI 300.0: 10602 CD-ROM (DVD)
[Created at block.247]
UDI: /org/freedesktop/Hal/devices/storage_model_DVD_RAM_GH22LS30
Unique ID: KD9E.c6GnszNG4b3
Parent ID: w7Y8.8XRgSiAmZd9
SysFS ID: /class/block/sr0
SysFS BusID: 3:0:0:0
SysFS Device Link: /devices/pci0000:00/0000:00:1f.2/host3/target3:0:0/3:0:0:0
Hardware Class: cdrom
Model: “HL-DT-ST DVD-RAM GH22LS30”
Vendor: “HL-DT-ST”
Device: “DVD-RAM GH22LS30”
Revision: “1.00”
Driver: “ata_piix”, “sr”
Driver Modules: “ata_piix”
Device File: /dev/sr0 (/dev/sg1)
Device Files: /dev/sr0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.2-scsi-1:0:0:0, /dev/disk/by-label/DVD_VIDEO, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
Device Number: block 11:0 (char 21:1)
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #17 (IDE interface)
Drive Speed: 48
Volume ID: “DVD_VIDEO”
Creation date: “2007091819250900”

Thanks for your help

well this is a quandry as this appears to be a fairly correct out put(as compared to my results) there are only a couple of things i can see that could cause the lack of functionality.

Config Status: cfg=no, avail=yes, need=no, active=unknown

one possibility is that its not recognized because its not configured into the system and there for doesn’t know how to activate and mount the device and an update of the kernel modules pertaining to dvd through yast.

the other issue is a little bit harder to pin down

Attached to: #17 (IDE interface)

there have been numerous threads started for issues with device cabled via ide(generally hard drives) and as you are using 11.1 this may very well apply to your machine as well.

while i believe it may be one of these 2 options i would focus on the first before recabling the drive.

an easy way to check the software end is to open a terminal and run the command

rpm -qa | grep libdvdread

if its not installed then it should be and if it is then rebuilding via yast may fix the problem.

let me know if this helps if not we look for another solution;)

Thank for your reply

THis this the output of the “rpm -qa | grep libdvdread”:

so it’s installed (??).
How can I rebulid it via Yast.??


I did this:
went install software utility
then reinstalled libdvdread3.

This did not solve the problem.

Ok. i think i figured out the issue(hopefully)
it is a couple step fix and i’m very hopeful that it corrects the issue

first open up yast software management
search for libdvdread and remove the libdvdread3 that you have installed, at the same time you’ll find libdvdread4(same list) click it to install click versions tab and ensure that it is comming from either dvd or the oss repo(not packman)

hopefully that will correct your problem. either way report back if there are any more porblems and i’ll be more than willing to try my hand again;)

Hi again,

thanks for your reply.
I’m sorry , but installing libdvd4 did not solve this problem.

first, when I tried to remove libdvd3 a conflict notification appeared. But I forced it to remove liddvd3. then installed dvd4 (which is not from packman).

however, it did install the libdvd4 , after removing dvd3, from a dvd media.

the error message is still :
Unable to mount location

DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
So what’s next?

well this is quite a puzzle.

next step is to check hwinfo again for any change in the config status. are you running compiz by any chance? i know i’m kinda reaching on that one;)

there was some extra Dbus functionality built into the newer versions of compiz-fusion

Hi again,

hwinfo --cdrom

Config Status: cfg=no, avail=yes, need=no, active=unknown

having gained a bit more insight;) back for another crack at it.

is your dvd present in your fstab info? if so remove it from fstab and try again, as in pop the dvd in and don’t try to force a mount through CLI

Can you please explain how can I have access
to the fstab file.
How can I remove the dvd from them.
and all related information.


Ignore the above reply.

this is the fstab file :

/dev/disk/by-id/ata-WDC_WD2500AAKS-00VSA0_WD-WMART1098461-part5 swap swap defaults 0 0
/dev/disk/by-id/ata-WDC_WD2500AAKS-00VSA0_WD-WMART1098461-part8 / ext3 acl,user_xattr 1 1
/dev/disk/by-id/ata-WDC_WD2500AAKS-00VSA0_WD-WMART1098461-part9 /home ext3 acl,user_xattr 1 2
/dev/disk/by-id/ata-WDC_WD2500AAKS-00VSA0_WD-WMART1098461-part1 /windows/C ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-WDC_WD2500AAKS-00VSA0_WD-WMART1098461-part2 /windows/D ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

and this is want I have for mount

/dev/sda8 on / type ext3 (rw,acl,user_xattr)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
debugfs on /sys/kernel/debug type debugfs (rw)
udev on /dev type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/sda9 on /home type ext3 (rw,acl,user_xattr)
/dev/sda1 on /windows/C type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda2 on /windows/D type fuseblk (rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
securityfs on /sys/kernel/security type securityfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
gvfs-fuse-daemon on /home/yotam/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=yotam)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)
/dev/sda6 on /media/disk type ext3 (rw,nosuid,nodev)
/dev/sda7 on /media/disk-1 type ext3 (rw,nosuid,nodev)

all done with root user

well i’m going to assume the issue is still present and if so there is one more thing to verify.

go into yast->security->group and user management

ensure that you are in the cdrom and disc groups


Thanks for your help.

I gradualy got convinced that there is some
conflict problem can not be solved by simple means.

So I’v reinstalled OS. Now , there is no mounting problem.

Thanks anyway

I had a few more problem. so reinstalling got more attractive
than solving it bit by bit

it happens to everyone from time to time. wish i could have been more help