DVD Playback Issue

I have no problems playing a DVD I burned. But a new DVD Movie straight out of the box I slap it in the ol DVD Drive and then click on Play DVD in Kaffeine and I get thee following 2 error messages.

  1. The source can’t be read.

    May you don’t have enough rights for this, or source doesn’t contain data (e.g: no disc in drive). (/dev/dvd)

  2. No plugin found to handlee this resource (dvd://)

    xine: cannot find the input plugin for MRL [dvd://]
    xine: input plugin cannot open MRL [dvd://]
    xine: found input plugin : DVD Navigator

I get no sound or video playback…This is directly after a fresh install of 11.0 on kde 4.1. After the install I updated using the repos found post that was stickied to top of this category on the forums. Then I just did the one click install for the codecs and got the above errors. Also all other movie file types work fine such as AVI, MPEG.

Have you installed libdvdcss2 and libdvdread ?

Also, don’t mix your packman and videolan rpms (with the exception of libdvdcss2 which comes from videolan). My recommendation is to not install videolan rpms and stick with packman packaged rpms for your multimedia.


Spare yourself the hassle and get LinDVD. Its
33 Euros or so.

LinDVD - Linuxland International

This also supports the professional development of application software for Linux.


H. :slight_smile:

thanks oldcpu:
a recent post in another forum: No Dvd Playback / Output On Mplayer ? - openSUSE Forums suggested libdvdcss2 was not on packman; certainly, YaST cannot identify it (nor libdvdread) on packman;

actually, as I review more posts, I see you commented in 2006
Libdvdcss - openSUSE Forums

that one could build a version of dvdcss2; it appears a complicated process;
PackMan :: Package details for libdvdcss2
is the videolan version really verboten just for one library?

re libdvdread:

RPM Search libdvdread.so.3

is this an acceptable source, as packman does not seem to have it

with the exception of libdvdcss2 which comes from videolan

You need to read more carefully.
Just install libdvdcss from the VLC repo - that’s it!
All the rest of the multi-media from Packman - even VLC player itself!

libdvdcss2 is version independent … ie same rpm works on all 32-bit opensuse versions. … hence if you have a 32-bit opensuse, you can install it per the instructions here (for 10.2 but works on 11.0):
Restricted Formats/10.2 - openSUSE-Community
What you need to send is the line highlighted in black that starts with "su -c … ".

I don’t have a 64-bit openSUSE, so I do not know what 64-bit users do for their libdvdcss2.

If you do adopt the “other” approach noted by caf4926, which is to add videolan to your repositories, then after you add the repos, and as soon as you finish installing libdvdcss2, I recommend you then remove videolan from your repositories. There are cases where rpms packaged by videolan do not work with rpms packaged by packman packagers, and one can lose a lot of their codec playback capabilities if one inappropriately mixes the rpms from the two repository sources.

OK I will try that and post back if it works here in a little while … and yes I did remove the videoLAN repos from repo list after the update using the 1-click install method … but we will see how it goes…





thanks oldCPU: I had already got libdvdcss installed: when I ran the su command from the restricted formats, it would not run, because libdvdcss was already installed; I used YaST to delete libdvdcss; and then ran the su command again; having verified that libdvdcss2 was installed, I reinstalled libdvdcss from videolan again; and both are now installed; I hope this is correct; and I will now remove videolan from the list of repos; this is all the time today to attend to forum matters; I do have more to answer, but must wait till tomorrow

Thanks for your input.

IMHO this is not 100% accurate. Many openSUSE users have experienced problems where some of their Packman packaged media players (such as kaffeine, which can use the xine engine) will not play many diffferent video files (with various codecs) when one has the videolan libffmpeg0 installed instead of the packman libffmpeg0 installed.

The simple work around (for these users with the codec problem) has been to remove the videolan packaged libffmpeg0 and install the packman packaged libffmpeg0. However I do not know the exact reason for this packman/videolan incompatibility, and there may be a different approach that will also work.

I had your item1 problem “the source can’t be read” using kaffeine. Kaffeine expects the link /dev/dvd, but my link after installing suse11.0 was /dev/dvd1. I moved /dev/dvd1 to /dev/dvd and low and behold kaffeine worked for me.

I still have a problem with Kaffeine. It went bad after i tried to update all multimedia. Now, after long battle I can play DVDs but with difficulties. If I just put disk in a drive default player gives me error message ( Kaffeine: Xine has only reduced set of codecs… ) which is not true for I’ve installed Packman / Vlc verions of libreries. But if I point player to dvd:///dev/hda it goes nice. I tried also to change device in preferences but it didn’t work. Any suggestion, please?

Uh, you mean your dvd device is /dev/hda? I’ve never heard of that before.

What do you mean by “updating all multimedia”? I am no expert but maybe in the process of updating you ended up with, for example, a older version of Kaffeine and a newer codec packages. What repos do you have enabled? How did you “update all multimedia”?

By “Vlc” do you mean videolan? If so, a number of us have observed that the videolan packaged codecs are often not compatible with the packman packaged players. Hence it behooves users who like to use packman packaged players, to stick with only packman packaged codecs, and not use videolan packaged codecs.

Even packman-builders recommend not to use Videolan with their packages at all. The conflicts between those two repositories seem to be even more aggressive on 11.0 than on 10.3 or 10.2. I used the videolan-repo for quite a while, but could solve these conflicts by hand - after upgrading to 11.0 there was no chance to do so in a sane way.