DVD Playback Complexity (SOLVED)

OK. I think I know my way around multi-media, but I’m not making much progress with this issue. It’s my Laptop (see sig) - Mostly it hardly ever plays movies etc… music yes - Anyway I had done the multi-media business on it when I installed 11.1 and I have played .avi files but never a movie dvd. The dvd mounts fine, I can browse it but nothing plays the dvd. (vlc, mplayer, smplayer, xine).

I have I’m sure all the necessaries installed, here is the 10 step output:


VLC spins up the drive then before GUI opens up it just quits. No errors.

SMPlayer fires up the GUI too, no image - a check of the menu seems to show it working thru the titles one at a time in rapid succession. Have to force a quit.

I tried Windows in Virtual box - it kinda plays but it’s all slow and distorted. But I think this is a graphics issue with the VM.

Yes: libdvdcss is installed.

I’ll trial this again, and if necessary post info or screens. But any advice is welcome. Thanks;)

are you sure you selected the right DVD title? In mplayer if you don’t specify the title to play, it defaults to title 1 which sometimes is not the correct one or is even empty thus mplayer will exit directly. When ran, mplayer prints the amount of titles on the DVD and you can select which one to play with dvd://2 … for example

It’s nothing to do with that micro.
here is a couple of shots
In file browser and terminal screen when trying to play in vlc

http://thumbnails12.imagebam.com/4554/9aac9c45539543.gif](http://www.imagebam.com/image/9aac9c45539543/) http://thumbnails12.imagebam.com/4554/3e602045539587.gif](http://www.imagebam.com/image/3e602045539587/)

Looking through your list, i don’t see libdvdcss anywhere. Is it installed ?


is that a new DVD? If so, it may have protection that dvdcss can’t crack - most new titles come with this kind of new protection so your best bet may be to run it through a Windows decrypter and let it strip it and spew out an ISO for you

Umm… Yes. It’s mentioned outside the list at the bottom of my comments.

rpm -qi libdvdcss
Name        : libdvdcss                    Relocations: (not relocatable)
Version     : 1.2.10                            Vendor: VideoLAN Project (http://www.videolan.org)
Release     : 6.1                           Build Date: Sun 08 Mar 2009 17:22:44 GMT
Install Date: Sun 10 May 2009 21:25:27 BST      Build Host: messiah
Group       : Productivity/Multimedia/Other   Source RPM: libdvdcss-1.2.10-6.1.src.rpm
Size        : 34320                            License: GPL
Signature   : DSA/SHA1, Sun 08 Mar 2009 17:22:58 GMT, Key ID 33de8fb7c8da93d2
Packager    : Dominique Leuenberger <dominique-rpm@leuenberger.net>
URL         : http://developers.videolan.org/libdvdcss/
Summary     : a simple library designed for accessing DVDs without having to bother about the decryption.
Description :
libdvdcss is a simple library designed for accessing DVDs like a block device without having to bother about the decryption.
Distribution: VideoLAN / 11.1

If this help. I can tell you dvd’s with no encryption play fine.

I have tried many dvd’s . The one in the drive now is Goldeneye. Fairly old dvd really.
In F10 Box - no problem.
I can rip it in k9copy in 10mins and it will play on the Laptop:

got libdvdread installed ?


 rpm --query --all 'libdvd*'

Thanks for your time guys so far!

I’m going to say the DVD player has no region set. Or a wrong region? Can you see what region it’s set to?

Got the idea from this -> DVDs don’t play in Suse 11.0- Still

Reason I’m saying it is he has the same type of laptop you have and
I can’t belief that you can’t get this to work. You’re the software multimedia guru! Well, one of them anyways :wink:

I’ll look in to this. It’s should be R2.

Interesting though. I have 2 dvd drives in my box. One has no region set, the other is R1 - Yet both work.

This shouldn’t be a problem for mplayer at least. It looks like something is fishy on either the DVD itself or on his system

You’re the software multimedia guru! Well, one of them anyways :wink:

A guru is someone who completely understands how video processing is done, like encoding, decoding, codec implementation, frame types and prediction, motion search algorithms/compensation, various bandwidth limiting techniques like interlacing and soft/hard telecine, DCT and inverse DCT frequency domains, quantization, Wavelet coding/compression, pre and postprocessing techniques and filters like debanding, denoising, dehalo, deblocking, degraining, Luma and Chroma controls and manipulations, etc, etc… so I doubt caf is a guru. Loren Merritt is one, as is Michael Niedermayer, Jason Garrett-Glaser and Mans Rullgard. Caf is better described as knowledgeable but certainly not as multimedia guru

Ok, Caf is a knowlegeable guru so… :stuck_out_tongue:
You guys and gals are all knowlegeable guru’s of the voodoo that is Linux!

I was only trying to give a complement. Not trying to insult the real guru’s…

I have a spare partition, so I’m going to install Windows and test it for real in that environment.

But Seeing that playback works well except with encryption I have to say it’s unlikely hardware at fault.
See you on the other side.

Since I neither see DVDs I just tested with a Friends one to verify the problem isn’t with the openSUSE packages.

mplayer dvd://
mplayer dvdnav://
xine dvd://
vlc dvd://
gst-launch playbin uri=dvd://

All of them work here. I even was surprised seeing GStreamer supports DVD menus (with resindvd plugin from plugins-bad).

I gave up fighting the codec war and coughed up for the fluendo codecs
and dvd player :frowning:

That being said I also use handbrake to eer backup my dvd’s and put
them on the NAS which has twonkymedia installed so I can stream to the
Xbox. Maybe compiling handbrake as it’s a standalone application may
help identifying if it’s a codec or hardware issue? Source is here;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 10 days 22:29, 2 users, load average: 0.09, 0.23, 0.26
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

I’m in Vista now and VLC isn’t playing it. So I have some work to do. Thanks for all the help. I will see how I progress and consider my options. I really don’t need to play them, but you know how it is.

Sounds to me like it’s the region settings or the drive itself. Maybe flash the firmware if you can. That’s known to solve some problems… and create others :wink:

It’ll have to wait until morning now. Thanks folks.

Thanks for this suggestion Dex.
I installed Vista in a spare partition. It’s Business edition so doesn’t support dvd playback, but VLC wouldn’t play until I put the region to 2 (PAL). It wasn’t set to any region.

So I repair my bootloader and try OS11.1
It works too. Mostly. Some DVD’s it will not unscramble. Yet my Box will. Go figure.

Thank you everyone!