DVD playback and regional code


I have problems with playing DVDs under Opensuse 11.1 (KDE4.2.2, 32 bit).

I installed all codecs (including libdvdcss), followed all guides and I’am also member of the groups “audio”, “disk” and “cdrom”

I think I have a problem with the regional code:

Fight Club (Regional code 2): Kaffeine shows something like “Ihre Eingabe konnte nicht geöffnet werden:
VLC kann die MRL ‘dvd:///dev/sr0’ nicht öffnen.”

LOST (season 3) (Regional code 2): Here, K9copy and kaffeine have the problem that they do not react (cpu usage up to 50%). No error message.

LOST (season 3, bonus disc) (Regional code 2): same as for the other LOST disc

Die Tiefseetaucher (The life aquatic) (regional code 2): The menu, to choose the language appears, afterwards the german notes, that you should not copy the movies appears and then it stops.

Rene Marik “Autschn” (didn’t find a regional code): Works!

Solaris from TV magazine (didn’t find a regional code): Works!

Now I tried the not working DVDs again with an external DVD drive:

Fight Club: Works with external drive!

LOST (season 3): not working. error messing the DVD is scrambled and I should install libdvdcss. Strange!

LOST (season 3, bonus disc): Works with external drive!

Die Tiefseetaucher (The life aquatic): Works with external drive!

Has my notebook (DELL precision M4400) problems with the regional code?
How can I see which regional code is adjusted? In case that it is not regional code 2, how can I change it?
Does somebody know something about regional code problems?



Seem to have 2 ways either do the dvd PackMan :: Package details for regionpatcher
Or the player if player can’t find an rpm… Also read this page and note 5 times.

Thanks for your answer FeatherMonkey :)!

But I think, I’am to stupid for it :(.

I installed regionpatcher, but when I try to start it in the console, I’am getting following answer: “Unable to fetch info from the VIDEO_TS dir, aborting…”
I have been also in the root folder and tried “regionpatcher -f media/LO30EUT4/” But I had no success.

I have the same problem with regionset:
“regionset /media/LO30EUT4” ends up with "regionset version 0.2-de – liest/setzt den Region Code von DVD-Laufwerken
FEHLER: Konnte nicht auf Laufwerk “/media/LO30EUT4” zugreifen!
Beachten Sie, es muss eine lesbare CD oder DVD im Laufwerk liegen.

I also tried out a second DVD (Solaris).
Where is my mistake regarding the path?




When using only “regionset” and not entering a path, I was able to see my regionalcode: there was non regionalcode installed. I set the regionalcode to “2”.
Now, I’am able to watch the above mentioned DVDs :slight_smile:

Thanks and Greetings


P.S.: Only one DVD is still refusing collaboration: the one LOST DVD, but here, I have no the same result as for the external DVD drive.

Glad you solved it never had to deal with it but had come across regionset along my travels. Strange there wasn’t a rpm or did you find one?

I used the rpm from “http://linvdr.org/download/regionset/
It worked.
In the bash (console) you have to be root before you can enter “regionset”



Sorry didn’t look there, just did a webpin search. Guess that’ll help someone else in the future.

you brought me on the right way ;). Thanks