dvd mounting

I am not sure whether it is not a hardware problem with my
Dell-Inspiron-1150 laptop or my 32-bit openSUSE-11.2 OS.
I have added ‘disk monitor’ in my panel.
When I insert a data-cd or a vcd in the optical disk tray the panel recognize the disk and shows it mounted. But when I put
a dvd, nothing is shown. I searched the forum and found that
I have W32codecs-all and libxine1-codecs installed, but could
not find libdvdcss/libdvdcss2 in the package list. I have
oss, non-oss, packman.unixheads.com, packman.mirrors.skynet.be,
and ftp.gwdg.de as my package-repos.
/etc/fstab has along with the other hard disks the following entries:
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

What shall I do to make the machine recognize dvds?

If you use kde dvd’s do not auto mount
But they will show in Dolphin if you have the places enabled from ‘View’ - Panels - Places

I have the Gnome version of openSUSE-11.2 installed from the
iso installation dvd.

Hang on, let me boot up a gnome system and see how it behaves.

This what happens for me:


Do NOT fiddle with fstab, it has nothing to do with it. DVD’s mount regardless of the installed codecs.

Did your install complete without errors.
Did you run the media check on the install media?

At the time of installation, I didn’t check the medium. But on
reading your mail I ran MediaCheckon the installation dvd with
the result : OK – The medium has been successfully verified.
However, I remembered that after the installatio I did have
some problem while shutting down. So I ran ‘Repair Installation’
with ‘Automatic Repair’. There were a number of Missing
Package Database, which were Repaired. But the mkinitrd
could not be repaired. So after logging in I added the oss,
and non-oss repo and disabling the ///cd I re-installed
mkinitrd. After that there was no problem at shutdown.

As a check I played the vcds and audio-cds with smplaer and
banshee, and found the sound completely garbled.
So there must have been some error in the installed packages.

As a curiosity, I played the vcds and audio-cds on
debian-5.0.3 my other OS in the same machine. And the
pictures and sound were perfect. But, here also only
some of the dvds were being shown mounted in the panel.
The erring dvds include BBC’s Shakepeare Collection DVDs.

I have laid open all the facts known to me.
Best regards.

Follow this:
Multi-media and Restricted Format Installation Guide - openSUSE Forums

Thanks caf and oldcpu(excellent guideline). Audio-cd and Vcds
are now working without any hiccough. Some problems are still
lingering about DVDs. Some DVDs are mounting but some are not.
Even for those that are playing, the sound is intermittant.

Every DVD is different and it’s a fact, that some might not play at all.