DVD does not install

I burned an image of 11.4 on a dvd, on start up to replace Ubuntu 10.4, I press F10 to boot form cd, the Suse page comes up I click on installation, and it makes a humming noise for awhile like it is going to install but then if finally stops that and that is it nothing else happens.

Did you do this

Check options from this:

Yes and the same thing happens.

What about the text mode install?

How do I do that?

Press F3 as shown here and select Text


None of the above options work, tried new dvd, same thing, must be a problem with the iso.

But you said it passed the media check?

No, I said the same thing happened which is after the screen with the options comes up it just made the ususal hum then stopped. Next I made a live cd, tried that it seems to want to work but it ends up with a screen full of green streaks, and does not go ahead. I can not remember a time when any of these things happened on trying a new distro. What can it be?

Also tried Live CD on another computer, same result, nothing but green streaks, does not work. Looks like I will stay with Ubuntu.

So I dug out an Ubuntu 10.10 cd tried it it works, the Mint Cd works, I just can’t get the suse live cd or the dvd to work for me. I like to try all the new distros, but this is a mystery that I have never before encountered.