dvd/cd drives

Has anyone had this problem, and fixed it. Please help.

I have 2 dvd/multi drives. Both of which is having the same problem. I am having trouble opening the trays, i have to push the eject button 20 or more times before the tray decides to open.

I know it is a linux problem because both drives work fine under windows xp.

The only time I can see my dvd/rom drive is when i have a cd in the drive. I always try to keep a cd in the tray at all times so I wont have that eject problem. I keep some form of cd in the tray at all times otherwise my dvd/rom doesn’t show up.

I actually hoped that by upgrading from 10.3 to 11.0 that my cd problems would solve themselves. I guess I am not going to be that lucky.

I did however figure out a new way to open my CD trays, I’m using a paper clip.

Thanks for any help.

Never come across this before. cd/dvd drives should only show when you have them loaded with media. Though actually I think, in kde3 you can choose to show all manner of mounted and un-mounted devices.

If they work in windows and not in linux, the drives must be ok. Are they peculiar in any way?

Hi
This probably should have been posted in the hardware forum. Have you
tried ejecting from the CLI?


eject /dev/sr0
or
eject /dev/sr1

That’s assuming they are called that dev name. You can confirm via the
following command;


hwinfo --cdrom


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
up 1 day 0:41, 2 users, load average: 0.27, 0.16, 0.31
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35

it is rare, but it’s possible that the firmware used is just not linux friendly. perhaps a firmware update will fix it.

Hi,

I think both is normal:

  1. Linux allows you to open the CD-drive only if it is not in use. So as long as a program reads the CD in it it won’t let you open it. Not that stupid as Windows which let you open it at any time and gives you an error afterwards. Before we had the auto mounter we even had to umount the CD to open the tray.

  2. Why do you want to see a drive with no media in it? That makes no sense. Linux just don’t bother you with that useless information.

hth

Bye

Erik

I have to push the eject button 20 or more times before the tray decides to open. OR I’m using a paper clip.

I don’t want to do these things anymore.

I want a normal cd-rom

I set up an external dvd drive just to test for differences. It behaved just as my original two.

My original dvd-roms is one internal one external. They did behave properly under openSuse of the past, they stopped behaving with openSuse 10.3 and 11.0.

If I wait long enough maybe some release in the future will fix them.