DVD Automounting UDF Problems.


I recently purchased an LG Super Multi drive for my system, to replace my older DVD Burner, when I installed the new drive, everything seemed to work great.

However, I have recently discovered that when I insert any DVD, (CDs seem to work fine, and I can boot off of DVDs) I get the following message:

mount: block device /dev/sr0 is write-protected, mounting read-only mount: wrong fs type, bad option,
 bad superblock on /dev/sr0, missing codepage or helper program, or other error In some cases useful
 info is found in syslog - try dmesg | tail or so 

The system log references:

May 20 18:24:13 home kernel: UDF-fs: No anchor found
May 20 18:24:13 home kernel: UDF-fs: No partition found (1)

I can force the mount via console, and using the ISO9660 file system, however when inserting the DVD, the system tries to mount the DVD as UDF, thus producing my error.

I have searched Google on this problem, and have found no solutions that work. I either need to change the way openSUSE is mounting DVD’s from UDF, to ISO9660, or find out why UDF isn’t working.

openSUSE 11.1 X86_64
KDE 3.5.10

LG Super Multi Drive SATA version

Thanks in advance for the help

Mark Brown

Anyone have any information on this issue? or perhaps a link to where I may receive some help?


One idea…do you have udftools package installed? I was also wondering if this is DE specific (as in KDE4.x?)


The problem isn’t DE specific, the system cannot read the DVD unless I manually mount it with ISO9660.

I also installed UDFTools, to no avail.

Thank you for you suggestions, any others?

Is this an external device?


Internal SATA , LG Super Multi Drive. Any idea’s?

can’t say I have any ideas really. How does it behave if you boot with failsafe?

Dear CynicalPride,

We had the same issue on #openSUSE-de with a LG drive.

Do you think you could find some time to open a bug report with some detailed hw information and the content of your initial post?

Best Regards

Anyone else have a solution to this problem? Or can tell me how to change the automount options, or where to find them?

Have a look at this archive thread
Suse 10.1 Automount Solution - openSUSE Forums


Sadly, I had already located and attempted that solution before creating my original post. It didn’t help unfortunately.

Thanks for trying

I have the same problem as the original poster. I even bought a new LG burner (only UKP 18) thinking the DVD laser had died.

It seems the problem is only on UDF DVDs. I can burn and verify a DVD with k3b, it won’t mount on my machine, but I can recover the data using dd on my machine, and the DVD reads on other machines.

The bizarre thing is, everything has worked fine seemingly for months. So some package I’ve updated or “tidied up” seems to be the cause. As for tidying up, I removed some KDE4 stuff because I run Gnome.

openSUSE 11.1 x86_64

mount: block device /dev/sr0 is write-protected, mounting read-only mount: wrong fs type, bad option,
 bad superblock on /dev/sr0, missing codepage or helper program, or other error In some cases useful
 info is found in syslog - try dmesg | tail or so

Woohoo! I’ve made some progress but I’d appreciate further help in eliminating this issue, which seems to affect many users if my Google results are anything to go by.

Credit where credit is due:
Ili Estas Simioj » 2009 » May
How to mount UDF format DVD+R on Ubuntu Jaunty

I can now mount a UDF DVD+R burned with k3b like this:

sudo mount -t udf /dev/sr0 /mnt -o ro,session=0,lastblock=1

If I omit lastblock=1 the mount fails with:

mount: wrong fs type, bad option, bad superblock on /dev/sr0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Now, it seems that some people are having fun with UDF disks written on Vista as multisession. It also seems that k3b attempts to write multisession disks by default - although I’ve never even tried to add a second session.

So I think the problem is caused by the combination of UDF and multisession. I’ll pursue this, but I’d appreciate feedback. I’m no guru or anything, just a methodical person working his way through Google results.

In due course, any help in configuring hal, gnome-mount, PolicyKit or whatever it is would come in handy.


Thanks for the message, I read the forums, but hadn’t bothered checking on this issue since it had seemed to die. In fact I had reinstalled my previous DVD burner, and gifted the LG to my kids in their machine.

I’m not sure how much your issue matches mine off the top of my head, I was able to mount the DVD media by forcing the iso9660 file system, as opposed to the UDF file system.

mount -t iso9660 /dev/sr1 /mount/media

I was looking for the same thing you seem to be looking for now, a way to change the command that is being used to automount the media. I am not familiar at all with HAL, policykit etc. etc. It seems no one knew the solution, thus I decided to live with my current drive, and pass the LG down to my kids, who use XP Pro.

If you make any further progress on the automounting issue, or someone has a solution for this problem, I would love to hear about it.


I found the gnome-mount command, but it doesn’t seems to recognise the options I passed to /bin/mount to make things work.

gnome-mount -d /dev/sr0 -f udf -o ro,session=0,lastblock=1

I’ve figured out (I think) how to enter any gnome-mount options in gconf so they are picked up by Nautilus.

Apropos mounting a DVD as iso9660, I think that’s fine unless any of your files exceeds 2 Gbytes.

I burned a test DVD with a 2.5 Gbyte file in k3b with the multisession flag set to None instead of Auto, that does not seem to have made any difference.

Woohoo! I think I’ve sorted this out. However, I’d advise caution because I haven’t regression tested in any depth.

So, the issue is how to tell gnome-mount to use session=0 and lastmount=1.

  1. Use the gconf-editor and using the left-hand pane drill down to the “folder”
  1. Edit the mount_options key by right clicking. My options now say

Looks good, but won’t work as-is, because you have to tell “hal” to allow you to use the options.

  1. As root (Danger Will Robinson), make a backup copy of and then use your favourite editor on the file

Around line 260, is a block of XML. Add the two lines I’ve highlighted in bold - be careful to add them in the right place!

      <!-- udf -->
      <match key="volume.fstype" string="udf">
        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="Linux">
          <append key="volume.mount.valid_options" type="strlist">uid=</append>
          <append key="volume.mount.valid_options" **type="strlist">umask=</append>
          <append key="volume.mount.valid_options" type="strlist">session=</append>
          <append key="volume.mount.valid_options" type="strlist">lastblock=</append>**
        <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name" string="FreeBSD">
          <append key="volume.mount.valid_options" type="strlist">-C=</append>
          <append key="volume.mount.valid_options" type="strlist">-v</append>
  1. Restart the hal daemon. One can do this inside YaST, but I used
sudo /usr/sbin/rchal restart

I then checked I hadn’t broken HAL by automounting a memory stick and a USB key.

The DVD+R mounts and is readable. :slight_smile:

A minor annoyance, which seems to be the new burner hardware, is that it takes a while for the system to realise that one isn’t reading from the DVD anymore, say ten seconds, before one can unmount and eject.