DV5-1155eg No Sound

Hi,

i have just installed openSuse 11.1. Everthing works except the sound. I have read many articles from diffrent forums and tryed a lot of thing, but nothing works and my laptop is still mute.

My Laptop is a HP DV5-1155eg.

Some outputs u may need:

rpm -qa | grep alsa

alsa-plugins-pulse-1.0.18-6.13
alsa-tools-1.0.18-1.16
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
alsa-1.0.18-8.9
alsa-plugins-1.0.18-6.13
alsa-driver-kmp-default-1.0.19.20090509_2.6.27.7_9.1-1.1
alsa-utils-1.0.18-6.4
alsa-firmware-1.0.17-1.42

rpm -qa | grep pulse

libpulse0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
pulseaudio-module-jack-0.9.12-9.5
libpulsecore4-0.9.12-9.5
libxine1-pulse-1.1.15-20.8
pulseaudio-module-bluetooth-0.9.12-9.5

rpm -q libasound2

libasound2-1.0.18-8.9

uname -a

Linux linux-rfix 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel

u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

I think here misses somthing, but i dont exactly know.

/usr/sbin/alsa-info.sh

http://www.alsa-project.org/db/?f=a2d656350c8a205a10f33da95d0e2a3c0351df5a

I am really desperated cause i don’t know what i should do. So i hope u can help me.

I note there an inconsistency between your alsa driver and your alsa libraries:

!!ALSA Version
!!------------

Driver version:     1.0.20-git20090509
Library version:    
Utilities version:  1.0.18

I also note there are no custom edits to your /etc/modprobe.d/sound file.

I know many HP DV5 users need to apply an edit to their /etc/modprobe.d/sound file to get sound working. So lets try that first. Please add a line to the start of your /etc/modprobe.d/sound file, such that that file now looks like this:

options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel
# u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller
alias snd-card-0 snd-hda-intel 

Then restart and test your sound. If that does not work, then post here, and we need to try to complete the update of your alsa driver to a consistent version 1.0.20.

Hi,

First thank you for your help.
ok i did what you say. I added the line:

options snd-hda-intel model=hp-m4 enable_msi=1
options snd slots=snd-hda-intel

u1Nb.uI7Vp9nVK5B:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

But i still have no sound.

Eh I forgot to mention that when I start openSuse I get a notice that the audio controller “HDA Intel (STAC92xx Analog)” doesnt work so it is changed to “HDA Intel, NVIDIA HDMI (HDMI Audio Output)”. Dont know if that can help you.

Please, what are you doing for a sound test? Please try each of these sound tests: SDB:AudioTroubleshooting - openSUSE - how to test your sound

If those don’t work, then we need to fix your installed alsa apps which are not aligned.

I tested both methods. But i heard nothing.

OK, please update your alsa to 1.0.20. You can do that by opening a konsole or gnome terminal, with your pc connected to the internet, and then type “su” ( no quotes - enter root password when prompted) and then copy and paste the following zypper commands in sequence, one at a time:

zypper ar http://download.opensuse.org/repositories/multimedia:/audio/openSUSE_11.1/ multimedia
zypper install alsa-oss alsa-oss-32bit alsa-utils alsa-plugins alsa-plugins-32bit alsa-tools alsa-firmware
zypper rr multimedia

then restart your pc and test your sound. Those commands are to update your alsa.

After rebooting, please check your mixer. Especially go to YaST > Hardware > Sound and ensure volume is up to 95%. I believe for the DV5 sound in the mixer is not linear, and one only gets sound in the upper range of the mixer volume settings.

Ensure you leave in place the edits I asked you to make to the /etc/modprobe.d/sound file.

Hi,

i followed your instructions and it works. After i had pulled the volume up to 95%, i had sound. So a tipp for everyone who has the same problem: Ensure that the volume is up to 95%.

Thank you oldcpu for your instructions to fix the problem.

Bye parad0x0n

Fantastic! I’m happy to read of your success.

Thankyou for sharing your solution.