Dumping Totem in favour of mplayer

I’m using Gnome desktop on Suse 11 and have set my preferred multimedia application as mplayer, using the preferred applications widget. However, when I insert a DVD Totem insists on opening and complains it doesn’t have the right codecs. How can I drop Totem totally in favour of mplayer? Any ideas?

Bump. Anyone?

one way is to edit the preferences in your system:

see this post:

made Adobe reader default: worked (Gnome) - openSUSE Forums

if you want to just examine the file /var/cache/gio-2.0/defaults.list

use gedit, if you use gnome; if you use kde … it’s … sorry I forget:

to edit the file, you need substitute user (root) access:

gnomesu gedit /var/cache/gio-2.0/defaults.list

you can replace an reference to totem with your favourite: mplayer?

or I guess: go into YaST; and delete totem??

I highly recommend the smplayer front end to mplayer:
SMPlayer - General Info

It is packaged for openSUSE by a packman packager:
PackMan :: Package details for smplayer

If your PC has internet access, and if you have packman (and OSS, Non-OSS, and Update) setup in your repos, then installing MPlayer and smplayer is a breeze.

I’ll second that. Make sure you check out the configuration options as well (as it has tons, and the mousebutton set up is ace). This seems to be one of the few programs under linux that actually does something with your mouses thumb-buttons.

You should be able to uninstall kaffeine completely by going to
Yast > Software management and doing a search for Kaffeine / select the uninstall option.

Thanks for all the helpful replies… problem sorted and the front end to mplayer installed!