dukto r6 (lan to lan transfer )app doesn't work ? in opensuse 13.1

Dukto is an easy file transfer tool designed for LAN use. You can use it for everyday work to transfer files from one PC (or other device) to another, without worrying about users, permissions, operating systems, protocols, clients, servers and so on… Just start Dukto on the two PCs and transfer files and folders by dragging onto it’s window

I’ve been trying to use dukto r6 (and also nitroshare - another lan to lan transfer app) with an windows 7pc and a laptop running opensuse 13.1 on it . The problem is that the one devices is unable to see other i mean dukto on opensuse. If I turn off firewall, everything is fine and both device sees each other and communicate well. The devices communicate and I can enjoy the almost unbias experience that dukto r6 brings to the linux desktop. If I activate the firewall, nothing works. I’ve tried to go to firewall-allowed service-Advanced but i was confused exactly what service should i configure . help needed can anyone help me to configure it and dukto working even if firewall is on

someone plz help, thanks in advance…!

When you want to allow traffic though the firewal, you have to open (a) certain port(s) in it. The application documentation (Dukto in this case) should tell you which port(s) are used.

actually i went through site but didn’t find any application documents so have mailed developers but they have there source code available at http://dukto.googlecode.com if anyone can look over it can tell which ports are to be kept open.

TCP/UDP 4644 according to a quick Google.

how to configure tcp /udp for port 4644 in firewall step by step can anyone help ,firewall settings seems to be confusing can anyone help plz…

YAST2 -> Firewall -> Custom Rules -> Add ->

Source Network is where you want the connection be allowed from, 0/0 means port is open FROM ALL IP addresses.
Protocol is TCP
Destination port is 4644

Source and Additional you can ignore.

You have to create another rule for UDP separately.

And the port number is what I got from Google - it might not be 100% certain as I do not use this application myself.

It worked fo’ rilla, thanks!!!