duel boot problem

im new to linux and have installed suse as a duel boot with vista 64, i can only boot lo linux using the cd other wise it just boots straight into windows, this is thats in my boot loader file

timeout 8
gfxmenu (hd0,5)/boot/message
##YaST - activate

###Don’t change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX
root (hd0,5)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WMAL91601517-part6 repair=1 resume=/dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WMAL91601517-part5 splash=silent showopts vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe – SUSE LINUX
root (hd0,5)
kernel /boot/vmlinuz root=/dev/disk/by-id/ata-WDC_WD1600BB-00GUA0_WD-WMAL91601517-part6 showopts ide=nodma apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 x11failsafe vga=0x31a
initrd /boot/initrd

###Don’t change this comment - YaST2 identifier: Original name: linux###
title VISTA
rootnoverify (hd0,0)
chainloader (hd0,0)+1

any help please, if you need any other info please ask but tell me how to get it in a idiots step by step stylee =)

cheers steve

Boot to SUSE, open a terminal and type:
su
then enter your password

now type:

fdisk -l

post result

I suspect the bootable flag is on the wrong partition

Do you remember where grub was installed (I suspect not to the MBR,)
I’m guessing Vista has the flag on it and grub is either to /boot or /

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xea264fc4

Device Boot Start End Blocks Id System
/dev/sda1 * 1 19458 156288000 7 HPFS/NTFS

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x106b106b

Device Boot Start End Blocks Id System
/dev/sdb1 1 2550 20482843+ 7 HPFS/NTFS
/dev/sdb2 2551 12386 79007670 7 HPFS/NTFS
/dev/sdb3 * 12387 19457 56797807+ f W95 Ext’d (LBA)
/dev/sdb5 12387 12648 2104483+ 82 Linux swap / Solaris
/dev/sdb6 12649 15245 20860371 83 Linux
/dev/sdb7 15246 19457 33832858+ 83 Linux

Disk /dev/sdc: 40.0 GB, 40027029504 bytes
255 heads, 63 sectors/track, 4866 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x14011401

Device Boot Start End Blocks Id System
/dev/sdc1 1 2550 20482843+ 7 HPFS/NTFS
/dev/sdc2 2551 3697 9213277+ 7 HPFS/NTFS
/dev/sdc3 3698 4866 9389992+ 7 HPFS/NTFS

Try switching the boot order of your HD’s in BIOS so sdb is 1st (if not already)
Report back on what the situation is.

in my bios i can only select HDD CD etc … no priority … just have them all set to HDD usually

Extremely unlikely, check, double check and check again…

Caf is right , it’s unlikely. There’s a giant post on the forum about openSuSE - Vista dual booting. You should find any solution there.

Question: why install a 64bit Vista (who’s making 64bit Windu software?), then again install 32bit linux?

I have thought some more and I still feel certain about the BIOS setting, it must be there.
But should you be unable to find it.

Try moving the sata connector of sdb to the first sata socket on the Mobo. But ideally you need to get an understanding of how these things work too.

SATA is in the 1st slot, it wouldnt boot to windows without being there for some reason

You are not making yourself very clear, which makes it difficult for us to help. Are we to assume you have 1 sata and 1 pata/ide?
And 1 external usb I guess.

If sdb is a older pata/ide
It must be set to Master
And it will need to be fist in BIOS if we are to boot from it and the grub code on it.

You absolutely must be able to set this in BIOS.