Dual Monitors Not Detected

Hi everyone

I had been using openSUSE 13.1 with Gnome and I have had no issues with my Dual Monitor Setup in the last 2 years. My system has an Intel HD Graphics (GPU on the CPU die) with the display connectors on the Motherboard. I have one of the monitors connected to the HDMI port and other to the DVI port from the motherboard. I also have an unused VGA port. Both the monitors are the exact same model. In openSUSE 13.1, I have my desktop extended across the 2 monitors without any issues.

Yesterday, I installed Tumbleweed from 20160605 Snapshot (with Gnome as the default environment) to a different partition on my hard drive and left the openSUSE 13.1 installation untouched. I used the Network Install ISO to do the installation. The installation went smoothly but after rebooting only one of the monitors ever seems to be used, right from boot time.

I opened Display Settings and it only shows one Monitor being detected. The other monitor remains in Power Savings Mode all the time, right since bootup (after selecting the menu item from GRUB).

I rebooted into openSUSE 13.1 and the dual monitor works fine there. I even did a quick comparison of the output from ‘xrandr -q’ and I noticed that HDMI1 and HDMI3 were the ones being used in openSUSE 13.1 whereas in Tumbleweed, only HDMI 3 is being used, although both the setups detect the same set of output ports (HDMI1, HDMI2, HDMI3, VGA, DP1). In Tumbleweed, the HDMI1 says Not Connected (or something similar).

I’m not right now in front of the computer to post the exact output from xrandr, but I will add this info in the evening.

Let me know what other information I can add to this post to help with the debugging. Any pointers or suggestions are welcome.

Thanks!

Hard to know might have changed here, but a possible regression with the intel driver

The following wiki page may be helpful here
https://wiki.archlinux.org/index.php/intel_graphics
In particular, the section titled ‘Module-based Powersaving Options’

Compare differences with any module options set between openSUSE 13.1 and Tumbleweed…

systool -m i915 -av

Can you trigger it on with something like

xrandr --output HDMI1 --auto

or by specifying a valid mode perhaps eg

xrandr --output HDMI1 --mode "1920x1200"

Anything reported by the kernel when you hotplug a second HDMI monitor?

dmesg --follow

or perhaps check Xorg log tail…

sudo tail -f /var/log/Xorg.0.log

FWIW, similar Ubuntu threads (so likely regression evident)
http://ubuntuforums.org/showthread.php?t=2314223
http://askubuntu.com/questions/736625/xrandr-does-not-connect-to-intel-i915-hdmi-output

Thanks, that really helped - the Ubuntu link you added :slight_smile:

This was the command which fixed it:

xrandr --addmode HDMI1 "1920x1080"

Then I fiddled around in the Display Settings Applet to arrange the windows correctly. I guess I could have also used xrandr to do this.

I’m not sure where these Settings get persisted, but they seem to stick after reboots. :slight_smile:

Glad that worked for you.

Then I fiddled around in the Display Settings Applet to arrange the windows correctly. I guess I could have also used xrandr to do this.

The display settings is the place to do it. Changes made with xrandr only are not persistent.

Anyway, thanks for posting back with your success as this may be helpful to others who come searching.