Dual Monitors Make Right Monitor Primary

I’ve tried everything but no matter what configuration I do the Left display is always made the default, so I have my screen reverse in the configuration putting my right screen at 0 0 and my left at 1980, tried putting my left screen at -1360 which worked but it still made the left screen the main which blew my 0 0 is primary, i even tried xrandr --output DFP3 --primary
DFP3 is my right screen which is the main one its the monitor
CRT1 is the left screen it is a tv i play movies on it thats it, don’t want it to be my main cause its kind of hard to look at when i’m using the keyboard

linux:~> xrandr
Screen 0: minimum 320 x 200, current 3280 x 1080, maximum 3280 x 1920
DFP1 disconnected (normal left inverted right x axis y axis)
DFP2 disconnected (normal left inverted right x axis y axis)
DFP3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080      60.0*+
   1600x1200      60.0  
   1680x1050      60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1360x1024      60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x960       60.0  
   1152x864       60.0     75.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       75.0     70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     67.0     59.9  
DFP4 disconnected (normal left inverted right x axis y axis)
CRT1 connected 1360x768+1920+0 (normal left inverted right x axis y axis) 570mm x 320mm
   1360x768       60.0*+
   1280x768       60.0  
   1280x720       60.0  
   1024x768       75.0     70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   640x480        75.0     72.8     59.9  
CRT2 disconnected (normal left inverted right x axis y axis)

Want DFP3 to be the default

linux:~> cat /etc/X11/xorg.conf
Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Monitor"
        Identifier   "0-DFP3"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1920x1080"
        Option      "TargetRefresh" "60"
        Option      "Position" "0 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Monitor"
        Identifier   "1-CRT1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1360x768"
        Option      "TargetRefresh" "60"
        Option      "Position" "-1360 11"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Monitor"
        Identifier   "0-CRT1"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
        Option      "PreferredMode" "1360x768"
        Option      "TargetRefresh" "60"
        Option      "Position" "1920 0"
        Option      "Rotate" "normal"
        Option      "Disable" "false"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option      "Monitor-DFP3" "0-DFP3"
        Option      "Monitor-CRT1" "0-CRT1"
        BusID       "PCI:1:0:0"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-1"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
        Screen      1
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Virtual   3280 1920
                Depth     24
        EndSubSection
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-1"
        Device     "aticonfig-Device[0]-1"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

linux:~> uname -a
Linux bedroom-linux 3.1.0-1.2-desktop #1 SMP PREEMPT Thu Nov 3 14:45:45 UTC 2011 (187dde0) x86_64 x86_64 x86_64 GNU/Linux

I’m not using the proprietary driver any longer (due to old ATI hardware), so someone who is may be able to assist more usefully than I can. Have you tried configuring dynamically with the proprietary ‘amdccle’ utility?

Unfortunately, I don’t have time to examine your xorg.conf configuration at the moment. Does /var/log/Xorg.0.log reveal anything useful here?

yeah nothing in the log about it, no matter how i do the config making either monitor primary with xrandr doesn’t change a thing it just sets the monitor to the left as the main screen had same issue on ubuntu, and debian

also gnome or kde no difference, using the catylist software same thing, seting the primary monitor in kde makes no difference. my desk is setup for the tv to go on the left side and the monitor on the right side, can’t imagine there is no way to make the computer do this, anyone else have dual monitors with the main screen on the left side?

only thing i can think to try is maybe using a vga cable for both monitors, cause right now tv is on vga and monitor is on dvi

Hi,
When this problem occur it tends a bit hard to solve.
While I am using nvdia graphic card.
I notice that it looks like the graphic card tend to
detect the crt(analog) first then the dvi then the last is hdmi.
In version 11.3 and 11.4 I was able to make the HDMI
as default against the DVI by removing the DVI cable
from the pc socket and boot using the HDMI. After that
I plugged the DVI cable to the pc and then run nvidia-settings
to enable the DVI connection. With this method HDMI became the
display-0 and DVI the display-1.

Now with my new installation of openSUSE 12.1 my trick doesn’t work
It always point to the DVI as the default display.

My installation is just new and I have not search around for the best solution
If I found one I will be back to share it here.

I’m not sure how well the proprietary fglrx driver works with xrandr extensions. You may want to try configuring with Xinerama enabled perhaps:

Xorg.conf for dual head fglrx

https://wiki.archlinux.org/index.php/ATI_Catalyst#Double_Screen_.28Dual_Head_.2F_Dual_Screen_.2F_Xinerama.29

BTW, similar behaviour reported here:

[64 bit] Very Confused: ATI fglrx aticonfig XrandR Dual Monitors, Big Desktop - Ubuntu Forums](http://ubuntuforums.org/showthread.php?t=1651165)