Dual Monitor Setup with KVM: Screen Keeps Reconfiguring

Hi.

Everything was working great for months, then a power outage happened, and now things aren’t quite the same…

I have a dual monitor setup via an NVidia graphics card. This works fine. I also have a KVM switch so that I can switch the second monitor to display another computer’s screen. This works fine too.

The problem I’m having now is when I switch the second monitor to the second computer, the first computer reconfigures from dual screen to single screen, thereby throwing every window, spread over two screens, onto one screen. I don’t want this to happen! I want the screen to remain the same. I just want to be able to see the second computer’s screen temporarily without affecting the screen of the first computer.

How do I prevent my boxen from reconfiguring its screen when it sees that one of the dual monitors is temporarily missing?

Thanks!

I’m not sure why this hasn’t affected me before, as it’s related to KScreen, which was last updated on my system May 7, 2020.

After more research, yes, it’s KScreen, which auto-magically reconfigures the desktop screen when monitors are added and removed. It’s a great feature to have, but not for my situation and for some others too.

General web search terms: “linux disable screen reconfig”

These turned up:

https://askubuntu.com/questions/858798/possible-to-have-xrandr-not-react-to-unplug-of-secondary-monitor-removal-of-hdm

  1. Create 90-my_nvidia_hacks.conf in /etc/X11/xorg.conf.d/ as root
  2. Paste a device section similar to this, but for the graphics card in your machine:

Section "Device"
    Identifier            "Device0"
    Driver                  "nvidia"
    VendorName    "NVIDIA Corporation"
    BoardName      "NVS 3100M"
    Option                "UseHotplugEvents" "false"
EndSection

The important part is Option “UseHotplugEvents” “false”.


https://forum.kde.org/viewtopic.php?f=66&t=161159

(Updated for openSUSE 15.1)

Settings->Configure Desktop->Startup and Shutdown->Background Services->Startup Services->KScreen 2 toggle to OFF


https://unix.stackexchange.com/questions/150513/how-do-i-stop-kde-from-changing-my-screen-resolution

(Updated for openSUSE 15.1)

  1. Edit $home/.config/kded5rc
  2. Add:

[Module-kscreen]
autoload=false

This does the same as toggling OFF KScreen 2 with the GUI.

Additional notes:

I’m using the first solution, with the file in /etc/X11/xorg.conf.d/. It’s most similar to my original experience and targets a specific graphics card; that way, if I had a second graphics card, it could still auto-magically reconfigure with KScreen.

If using the first solution, make sure none of the other files in xorg.conf.d have a Section “Device”. This is the warning:

Having multiple “Device” sections is known to be problematic. Make

sure you don’t have in use another one laying around e.g. in another

xorg.conf.d file or even a generic xorg.conf file. More details can

be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.